Opened 3 years ago

Closed 3 years ago

#1778 closed error (answered)

FCM on archer does not recognise keywords

Reported by: swr05npk Owned by: annette
Component: FCM Keywords:
Cc: Platform: ARCHER
UM Version:

Description

I am trying to run the standard GA6.0 N96 AMIP simulation at UM 10.3 on ARCHER. I copied suite u-aa894 into my suite u-ab340 and adapted it (with some difficulty) to submit to ARCHER. The difficulty arose because there were only two choices for HPC system in the Met Office job: Met Office and NCI (Australia).

Anyway, the suite fell over when it tried to run the INSTALL_ANCIL_RESOURCE task on ARCHER. It crashed with the following error:

[FAIL] file:/work/n02/n02/pappas/cylc-run/u-ab304/share/data/etc/um_ancils_gl=source=fcm:ancil_data.xm_tr/ancil_versions/n96e_orca025/GA6.0_AMIP/v5/ancils: bad or missing value

From puma, I can see that this file exists, because

fcm extract fcm:ancil_data.xm_tr/ancil_versions/n96e_orca025/GA6.0_AMIP/v5/ancils

succeeds. However, on ARCHER:

fcm extract fcm:ancil_data.xm_tr/ancil_versions/n96e_orca025/GA6.0_AMIP/v5/ancils

Extract command started on Fri Dec 18 16:42:31 2015.
->Parse configuration: start
[FAIL] fcm:ancil_data.xm_tr/ancil_versions/n96e_orca025/GA6.0_AMIP/v5/ancils: location keyword not defined

So I suspect my suite failed because FCM on ARCHER cannot resolve the ancil_data.xm_tr keyword. Indeed, issuing

fcm keyword-print

on ARCHER yields no output, while on puma the same command prints loads of keywords and their respective paths.

I managed to get around this issue by installing the ancils file in my /work directory, then pointing the Rose suite to that file, but it seems to me that FCM on ARCHER should be able to resolve keywords if these suites to work "out of the box".

Change History (2)

comment:1 Changed 3 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hi Nick,

The issue is that the UM-related PUMA repositories are not accessible from Archer. It would be best to use your work around for now, and we can think about how to support this in the future (well when Ros is back in January).

We are not really at the point of suites running out-of-the-box on Archer yet. We can discuss this offline.

Annette

comment:2 Changed 3 years ago by annette

  • Resolution set to answered
  • Status changed from assigned to closed

As a follow up, we don't think it will be possible to access the repos from ARCHER because of issues to do with authentication. The way round it would be to get the task to extract on puma and mirror to ARCHER (as with the code), or to copy from a standard location (as in your work-around). Interestingly, the GA7 suite that Ros is using does this rather than an extract.

Annette

Note: See TracTickets for help on using tickets.