Opened 3 years ago

Closed 3 years ago

#1780 closed help (answered)

pp endianess MONSooN archiving

Reported by: PUMA_GarryHayman Owned by: um_support
Component: UM Model Keywords: ff2pp endianess archiving
Cc: Platform: MONSooN
UM Version: 6.6.6

Description (last modified by ros)

Hi, I would be grateful for some assistance.


I am archiving some MONSOON runs to the MASS storage. For space reasons, I converted the output files to pp format using ff2pp (and since deleted the original field files). When I tried to archive these to MASS using the moose put command, I received the following error (see /projects/jules/ghayma/z_ARCHIVING/xlrlg/xlrlg/file_0001.pm.moo.err):


/projects/jules/ghayma/xlrlg/xlrlga.pmk9dec.pp: (ERROR_CLIENT_INVALID_FILE_FORMAT) attempted to archive a file of the wrong format for the collection.
File does not appear to be in canonical PP format
put: failed (2)


I have compared this pp file in xconv with others. I see that it should be in a ‘byte-swapped 32-bit ieee pp’ format rather than ‘32-bit ieee pp’. Is this the cause of the failure? Is there a way of converting the pp file?


I looked at an IBM job and see that in the nerc archiving branch the conversion to ‘byte-swapped 32-bit ieee’ pp file uses ieee and convpp (see /projects/jules/ghayma/xldko/bin/qsmonsoon_nerc_arch):


if [[ "$UMPP" = "Y" && "$FF2PP_NERC" = "Y" ]]
then
   ieee -32 $CURRENT_RQST_NAME $TEMP/${CURRENT_RQST_NAME}_32
   $CONVPP_DIR/convpp -32 $TEMP/${CURRENT_RQST_NAME}_32 \
                          $ARCHIVEDIR/${CURRENT_RQST_NAME}.pp
   rm -f $TEMP/${CURRENT_RQST_NAME}_32
else
   cp $CURRENT_RQST_NAME $ARCHIVEDIR
fi


Should I use these instead of ff2pp or is there a flag that I should set?

Change History (2)

comment:1 Changed 3 years ago by grenville

Garry

ff2pp used the native endianess of the machine - you can make your pp files big endian with

$UMDIR/bin/bigend -32 filein fileout

ieee and convpp should work ( they are lifted directly from the MO machine), but we've not tested them.

Best

Grenville

comment:2 Changed 3 years ago by ros

  • Description modified (diff)
  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.