Opened 4 years ago

Closed 4 years ago

#1797 closed help (fixed)

vn8.4 release job for ARCHER

Reported by: akpandeyjnu Owned by: luke
Component: UKCA Keywords:
Cc: luke Platform: ARCHER
UM Version: 8.4

Description

Hello,

I'm having an issue with the vn8.4 release job (xlavb). I've copied it and created a new job with Job Id xmjwb. I've changed the user ID, email, job run length, and the model run time.

The job starts running but fails almost immediately and contains this error:


ERROR EXPPXI: INVALID row VALUE: 0
Im_ident,Sec,Item: 1 34 50

????????????????????????????????????????????????????????????????????????????????
??????????????????????????????????? WARNING ????????????????????????????????????
? Warning in routine: PRELIM
? Warning Code: -10
? Warning Message: Diagnostic discarded model 1 section 34 item 50 No stashmaster record
? Warning generated from processor: 0
????????????????????????????????????????????????????????????????????????????????


As you can see it says diagnostic 34050 is not in the STASHmaster. It also doesnt show up in the umui anywhere.

Do you what's going on here? Is it an issue with a hand-edit? There seem to be quite a few that are different to the job I'm using.

Declan Finney has encountered a similar error with job xlqta. He's run it before and it ran without an issue, but when he tries to run it again, he's encountered the same error. We looked at the branch fcm:um_br/pkg/Config/vn8.4_ncas/src and noticed that there were some recent changes. Perhaps this could be the issue?

Regards

Alok

Change History (8)

comment:1 follow-up: Changed 4 years ago by grenville

Alok

Please tell us where the leave file is.

Grenville

comment:2 Changed 4 years ago by luke

  • Owner changed from um_support to luke
  • Status changed from new to accepted

comment:3 Changed 4 years ago by luke

Hi Alok,

I have taken a copy of your xmjwb job (my xleqb job) and it ran fine for me:

xlqeb: Run terminated normally

The message above is just a warning (although I didn't see it).

Also, what are your .profile/.bashrc settings? You should follow the settings as per here:

http://puma.nerc.ac.uk/trac/UM_TUTORIAL/wiki/UmTutorial/SettingUp

Although you are using vn8.4.

Can you check these things, then copy your job and just try to run it again. Do you get the same message?

Thanks,
Luke

comment:4 Changed 4 years ago by s1251469

I'll leave alok to point you towards the correct leave file.

However, I thought I would comment that there is also a line about qsserver failure. Having looked this up there are tickets suggesting to turn of automatic post-processing. When I do this my job runs and I will get Alok to check if his does too. However, can you think of what might be stopping archiving?

Is it an ssh issue on archer as suggested in this ticket?
http://cms.ncas.ac.uk/ticket/1656

I realise now that my archiving is set to archive in /work. I know this is utterly pointless but perhaps the issue is specifically being able to archive to rdf?

comment:5 Changed 4 years ago by luke

To archive to /nerc you need to follow the instructions here. I have done this and the /nerc archiving works fine for me, so if this is the issue, I wouldn't be able to test for it.

http://cms.ncas.ac.uk/wiki/Archer/NercArchiving

If you archive to /work I don't believe you need to do anything in particular, as you don't need the ssh keys to be set-up.

Thanks,
Luke

comment:6 in reply to: ↑ 1 Changed 4 years ago by akpandeyjnu

Hi Grenville,

The leave file is output/xmkgb000.xmkgb.d16028.t130704.leave

I am attempting to do it again using automatic post processing turned off.

Alok

Replying to grenville:

Alok

Please tell us where the leave file is.

Grenville

comment:7 Changed 4 years ago by akpandeyjnu

Hi,

I did changes as suggested by Luke. It works well now.

Thanks
Alok

comment:8 Changed 4 years ago by luke

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi Alok,

That's great - I'll close this ticket now. Any new issues, please open another ticket.

Thanks,
Luke

Note: See TracTickets for help on using tickets.