Opened 13 years ago

Closed 13 years ago

#18 closed help (fixed)

xbrta (full climate run) compile errors & modsets

Reported by: tea@… Owned by: lois
Component: UM Model Keywords: MODSETS
Cc: Platform:
UM Version:

Description

'm trying to run the example job xbrta (xceja is my experiment). beech:

When this is done "as is" the compilation eventually fails with the error: "ioerr1a.f", line 94.12: 1513-039 (S) Number of arguments is not permitted for the INTRINSIC procedure "abort". ioerror === End of Compilation 1 === (see /hpcx/home/n02/n02/arbetter/um/umui_out/xceja000.xceja.d06310.t151741.comp.leave)

So I searched and found that this error is handled in a deck modset /hpcx/home/n02/n02/umx/vn6.1/mods/pum_full_6.1.mf77

But this modset isn't included in SubModelIndependent?ScriptInserts?? (only the .mu modsets are)

Various attempts to include the mf77 modsets failed, with errors like (in /hpcx/home/arbetter/um/umui_out/cejb000.xcejb.d06307.t171252.comp.leave)

The following script modsets will be used:$PUM_MODS61/pum_full_6.1.mf77$PUM_MODS61/pum_full_6.1_ksh_comp.mu$PUM_MODS61/script_archfix.mu$PUM_MODS61/um_archive61_hpcx.muEnd of ListCompleted?? with 19 error(s) and 10 warning(s).updscripts: Error in nupdate commandupdscripts: Nupdate command was :-pumscm -p /hpcx/home/n02/n02/umx/vn6.1/normal/source/umsl -i /hpcx/tmpchkpt/jtmp/l1f401.95345.0/tmp/xceja.updates -d -F -M

corresponding with (in /hpcx/devt/n02/n02-ncas/arbetter/xceja.out):

updscripts: %UPDATES% output follows:-

PUMSCM: version 1.21 (2003/06/19). © Met Office Error : Deck IOERR1A not found in Program Library (Modset AAD1F602)

Ignoring all modifications to this deck.

So, this only happens in the full run (atmos + ocean); the atmos-only run compiles and runs successfully.

I tried making a simple modset in ~arbetter/umod/vn6.1/toddmod.mf77 but that didn't work either.

Change History (2)

comment:1 Changed 13 years ago by admin

I forgot to change my username from umdoc; I am the one who submitted the ticket if you couldn't tell from the context.

todd

comment:2 Changed 13 years ago by admin

  • Resolution set to fixed
  • Status changed from new to closed

I have copied this standard job and changed it to use my userid on HPCx and to the compile the model code. This worked fine.

I didn't compile the reconfiguration as this is not required for this particular standard job. The job has not been set up to compile the reconfiguration. If you want to compile the reconfiguration then please use the Reading standard job xbrte as an example.

We could change the the Reading standard job xbrta to use the reconfiguration but then this would not really be what the job is it is an example of the Hadley Centre IPCC run.

Lois

Note: See TracTickets for help on using tickets.