Opened 3 years ago

Closed 3 years ago

#1816 closed help (answered)

xancil does not convert all time dimensions

Reported by: ucfaako Owned by: jeff
Component: UM Tools Keywords: xancil, netCDF, ancillary
Cc: Platform: ARCHER
UM Version: 6.6.3

Description

Hello,

I've been trying to create a new vegetation disturbance ancil with the pre-defined xancil Disturbed Vegetation Fraction menu but it only converts the first year. The input netCDF has 101 time slices starting at 1860-01-01. I have tried both, setting the ancillary file dates manually to Year 1860 | Month 1 | Day 1 | Hour 0 etc, number of times 101 (also tried less than 101) and value of time interval to 1 year as well as letting xancil extract the specified dates from the netCDF. When checking in xconv the date is always set to 0000-01-01, no matter what the input date was.
The netcdf, ancil and namelist files can be found in
/home/n02/n02/akncas/ancils
I'm probably missing something obvious but any help would be greatly appreciated.

Many thanks,
Alex

Change History (3)

comment:1 Changed 3 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Alex

When this part of xancil was written there wasn't any time dependant vegetation disturbance ancil files available, so it is only possible to create single time files for this ancillary type. I can certainly put this on the list of things to add to the next version. In the mean time it should be possible to create this file using the "Generalised Ancillary Files" option. You will need to enter more information to do this, let me know if you need any help with this.

Jeff.

comment:2 Changed 3 years ago by ucfaako

Hi Jeff,

many thanks that worked well!

Alex

comment:3 Changed 3 years ago by jeff

  • Resolution set to answered
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.