Opened 4 years ago

Closed 4 years ago

#1819 closed help (answered)

SCM Namelist

Reported by: DanielSmith Owned by: willie
Component: UM Model Keywords: SCM
Cc: ricky.wong@… Platform: ARCHER
UM Version: 8.6

Description

Dear CMS helpdesk,

I have been trying to run an experiment using the SCM. I have created a namelist (/work/n02/n02/dansmith/SCMDATA/test_int_vert70_land.nml) for my experiment by altering another namelist. I have managed to initialise and force the model the way I would like, however; when I try to alter the surface from sea to land I receive the following error;

forrtl: severe (24): end-of-file during read, unit 10, file /work/n02/n02/dansmith/SCMDATA/test_int_vert70_land.nml, line 338, position 0
Image              PC                Routine            Line        Source
xmgmh.exe          000000000146079B  Unknown               Unknown  Unknown
xmgmh.exe          00000000008DE2FA  Unknown               Unknown  Unknown
xmgmh.exe          00000000008AAEFE  Unknown               Unknown  Unknown
xmgmh.exe          000000000045D36B  Unknown               Unknown  Unknown
xmgmh.exe          0000000000409FA6  Unknown               Unknown  Unknown
xmgmh.exe          00000000004012E6  Unknown               Unknown  Unknown
xmgmh.exe          00000000014FC9B1  Unknown               Unknown  Unknown
xmgmh.exe          00000000004011B5  Unknown               Unknown  Unknown
xmgmh: Run failed

The log file is /home/n02/n02/dansmith/test_3.
I have tried various ways of the changing the &INMOSES section of the namelist and still have the same error when running the model. The alternative namelist which does work is /work/n02/n02/dansmith/SCMDATA/test_int_vert70_land.nml.

Kind regards,
Dan

Change History (9)

comment:1 Changed 4 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted
  • UM Version changed from <select version> to 8.6

Hi Dan,

The problem is the new namelist

/work/n02/n02/dansmith/SCMDATA/test_int_vert70_land.nml

There is something missing - a sub namelist perhaps, or insufficient parameters provided - so the program reads past the end of the file.

Is

/work/n02/n02/dansmith/SCMDATA/test_int.nml

the working namelist? If so a direct comparison might help. Did xmgmf work?

Regards,

Willie

comment:2 Changed 4 years ago by DanielSmith

Hi Willie,

/work/n02/n02/dansmith/SCMDATA/test_int.nml
is the working namelist. I don't have a job created for this namelist as I just changed the namelist in the UMUI for xmgmh.

xmgmf does work but it is just a copy of xlmjb.

Many thanks,
Dan

comment:3 Changed 4 years ago by willie

Hi Dan,

In the INMOSES name list, try adding a comma to the lines for z0_tile and infil_tile and see if that works.

Regards

Willie

comment:4 Changed 4 years ago by DanielSmith

Hi Willie,

I have just tried adding the commas and I receive the same error. The log file is

/home/n02/n02/dansmith/test_4

Regards,
Dan

comment:5 Changed 4 years ago by willie

Hi Dan,

After some experimentation, I found that setting land_points=0 in CNTLSCM "solves" the problem. I guess that some of the later values are calculated incorrectly from the land points.

I hope that helps.

Regards

Willie

Last edited 4 years ago by willie (previous) (diff)

comment:6 Changed 4 years ago by DanielSmith

Hi Willie,

Unfortunately setting land_points=0 reverts the surface back to a sea point rather than a land point and thus producing the same output as the test_int.nml as all the other information I have changed in test_int_vert70_land.nml isn't used.

I have tried commenting out the information in INMOSES similar to the test_int.nml hoping this would use default values for this information, however; this still reproduces the same error. Therefore, just setting land_points=1 and land_sea_mask=true without making any other changes to test_int.nml causes this same error.

Are there any alternatives to solve this problem?

Many thanks,
Dan

comment:7 Changed 4 years ago by willie

  • Cc ricky.wong@… added

Hi Dan,

My point was that there is an inconsistency in the name list file somewhere. One thing I did notice was that there is no name list called INMOSES in the code, but there is one called INJULES.

I've never used the SCM myself, so I can't really comment on the correct setup. Maybe Ricky Wong at the Met Office might be able to help?

Regards,

Willie

comment:8 Changed 4 years ago by DanielSmith

Hi Willie,

Thanks for your help.

Kind regards,
Dan

comment:9 Changed 4 years ago by willie

  • Resolution set to answered
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.