Opened 12 years ago

Closed 10 years ago

#182 closed help (fixed)

Read ECMWF ERA40 data

Reported by: anmcr Owned by: lois
Component: UM Model Keywords:
Cc: Platform:
UM Version: <select version>

Description (last modified by lois)

Hello,

I want to run the UM with ERA40 data. Could I get some advice/feedback?

1) I have run UM 6.1 on HECTor. But UM Doc 303 informs that this version reads 'ECMWF pressure level data'. However, from vn 6.5 and beyond the model can read 'ECMWF ERA40 data'. Can I run vn 7.0 on HECToR?

2) UM 6.1 can run using ECMWF analysis. The difference between ECMWF analysis and ERA40 analysis seems to be that ECMWF analysis archives 'SP', while ERA40 archives 'LNSP'. Would a simple modification of the code to change LNSP → SP suffice to get UM 6.1 running using ERA40 data?

Thanks,

Andrew Orr (anmcr)

Change History (5)

comment:1 Changed 12 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Andrew,

you need to read the NCAS technical document
http://ncas-cms.nerc.ac.uk/content/view/671/182/
which tells you about starting the UM from ECMWF data in the academic community rather than at the Met Office.

On PUMA there is an example job for starting the UM from ECMWF data on HECToR. Filter using the userid umui and the job is xdkea.

Let us know if there are any problems.

Lois

comment:2 Changed 12 years ago by anmcr

Hello Lois,

Thanks for this information. It was useful.

I have managed to reconfigure the UM using ECMWF analysis start data, using the NCAS example job as a basis file. However, the job fails if I try to reconfigure with ECMWF ERA40 start data. I have attached the section of the .leave file which contains the error message. Stashcode 409 is 'surface pressure after timestep'.

The problem may be with the parameter identifier of the required surface pressure field. ECWMF analysis used the identifier '134.128', while ECMWF ERA40 uses '052.162'.

One possibility might be to modify the grib header of the ECMWF ERA40 data. Or modify the UM code so that it looks for field '052.162'. But surely someone has encountered this problem before?

Can you give any advice?

Thanks,

Andrew

*

aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 9) - process 15

ERROR!!! in reconfiguration in routine Rcf_Locate
Error Code:- 10
Error Message:- Unable to Rcf_Locate field with STASHcode 409
Error generated from processor 0
*

aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 9) - process 0
[NID 1408]Apid 487623: initiated application termination
/work/n02/n02/anmcr/tmp/tmp.nid00007.23872/modscr_xdmvd/qsexecute: Error in dump reconfiguration - see OUTPUT
*

Ending script : qsexecute
Completion code : 137
Completion time : Tue Nov 4 10:35:51 GMT 2008

*

comment:3 Changed 12 years ago by lois

Hello Andrew

the UM code should be able to cope with the difference between ERA40 and ECMWF analyses and the log pressure /pressure field difference. The Met Office say that we should be able to use ERA40 with no problem. So the fact that your reconfiguration job fails suggests that we may have something we need to change something in the HECToR vn 6.1. I will investigate and get back to you as soon as possible.

Lois

comment:4 Changed 12 years ago by anmcr

Hello Lois,

I took the ERA40 GRIB file and modified the 'surface pressure' parameter identifier from '052.162' to '134.128'. This worked. As I was able to reconfigure the ERA40 start file to a UM global start file.

However, as you mentioned it is strange that this step was required.

Andrew

comment:5 Changed 10 years ago by lois

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from accepted to closed
  • UM Version set to <select version>
Note: See TracTickets for help on using tickets.