Opened 3 years ago

Closed 3 years ago

#1825 closed help (fixed)

Require advice on changing compiler version

Reported by: markr Owned by: willie
Component: UM Model Keywords: compiler version, openmp
Cc: Platform: MONSooN
UM Version: 8.6

Description

Hello,
I have been advised by Cray to use a more recent version of their compiler with my vn8.6 OpenMP work. I am using Monsoon but ask here as someone might have advice on where to look (because it won't build). CCE on Monsoon default is 8.3.4.

My job xwlzf uses a hand edit to activate "module swap cce cce./8.4.3"
in FCM_BLD_CMDS and that seems to have worked.
However the build failed. No sensible mesages either.
A separate suggestion was that I might have to turn off pre-build but I believe that is already the case for Monsoon.
I checked Model Selection > FCM Configuration > FCM Options for Atmosphere and Reconfiguration and it shows "use precompiled build" as not selected.

I do wonder if there is anything in "bindings location" that is compiler version specific.

Any suggestions welcome.

Many thanks,
Mark

Change History (6)

comment:1 Changed 3 years ago by markr

Ooops my UMUI jobid is xlwzf sorry for typo!

comment:2 Changed 3 years ago by markr

I just tried a debug build (instead of "safe climate") and the log file shows:

ftn-3178 crayftn: LIMIT in command line
  There is a problem with a temp file or a program library file being used in this compilation.
make: *** [ukca_setup_indices.o] Error 1
make: *** Waiting for unfinished jobs....

Which suggests (to me) somewhere something is being built at a different compiler level.
Unfortunately with -j 5 option to make is difficult to see which comile is actually generating the message.

I could try again with no parallel make.

Last edited 3 years ago by markr (previous) (diff)

comment:3 Changed 3 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Mark,

I have been using

module swap cce/8.3.4 cce/8.3.7

on MONSooN for a while now. We also use this version on ARCHER (XC30).

Regards

Willie

comment:4 Changed 3 years ago by markr

Thank you Willie
I have just tried that (I left make -j 1 so it took a while to get to that point).
Unfortunately that version too does not compile the routine with
the openMP clause COLLAPSE(2) unless I make explicit loop limits. The Cray advice was to
use cce8.4.+ which is why I was trying 8.4.3

I will try 8.3.12 as it is the highest 8.3 available.

Mark

Last edited 3 years ago by markr (previous) (diff)

comment:5 Changed 3 years ago by willie

Hi Mark, You might also need to recompile GCOM if you switch compilers. Having the wrong GCOM could cause run time problems.

Regards

Willie

comment:6 Changed 3 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.