Opened 12 years ago

Closed 12 years ago

#183 closed help (fixed)

Inconsistency in modsets for a global run in HECToR...?

Reported by: oma Owned by: willie
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Dear All,

I'm trying to run the global model on HECToR in order to generate LBCs for a LAM run. The job ID is xdmxa. I had done this before (two/three weeks ago) and everything was fine. However, now that I'm trying to use the same setup again (without any change) I'm finding the following error message in the .comp.leave file

qsmain(106): * Starting Fortran77 nupdate

Completed with 1 error(s) and 1 warning(s).
/work/n02/n02/oma/tmp/tmp.nid00008.17944/modscr_xdmxz/qsmain: Model xdmxz - Error(s) in Fortran77 code update step

qsmain: %UPDATEF77% output follows:-


PUMSCM: version 1.21 (2003/06/19). © Met Office
Error : Cannot modify *PURGEDK'd deck QPOS2A (Modset PUM61FMODS)

Ignoring all modifications to this deck.

I've downloaded the example UMUI job xdgna with exactly the same unsuccessful results and error message. From this message it seems as though there is some inconsistency between the MODSETs to be used in this case. Has there been any change recently in these?

Any suggestion will be greatly appreciated.

Thanks,

Oscar

Change History (3)

comment:1 Changed 12 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to assigned

Oscar,
How strange! I noticed this in your global job xdmba and I simply switched off the offending mod. and this worked. I will investigate further.
Regards
Willie

comment:2 Changed 12 years ago by jeff

Hi Oscar/Willie?

This is caused by a change I made to pum_full_6.1.mf77, to fix a bug in qpos. The problem is mod qpos_fix_opt.mf77 removes deck QPOS2A and replaces it with a new version, then my mod comes along and trys to change lines that no longer exist. I have backed out this change to pum_full_6.1.mf77 so the problem should no longer occur. This mod fixed a problem which caused the model to crash on the X2 vector machine, the XT4 also has the problem but here it doesn't make the model crash or effect the results, so it doesn't matter if these changes are removed for most people.

Jeff.

comment:3 Changed 12 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.