Opened 3 years ago

Closed 3 years ago

#1833 closed help (fixed)

Compilation failure probably related to module changes

Reported by: earhg Owned by: ros
Priority: normal Component: UKCA
Keywords: Cc: luke.abraham@…
Platform: ARCHER UM Version: 8.4

Description

Hi,
Today I am having trouble compiling a job xmmll that worked fine, or at least (manually) compiled fine, two weeks ago. I think it might be caused by the module changes on ARCHER. The error is below (full trace at /home/n02/n02/earhg/compile_xmmll.log). I tried using "module swap" on the command line before compiling to manually revert the module changes made in ARCHER that I saw in "module list" but that didn’t work. I guess something could be missing from my .profile?

I am new to UKCA, so please spell things out as much as possible.
Many thanks for any thoughts or help!
Best,
Hamish

ftn-3178 crayftn: LIMIT in command line

There is a problem with a temp file or a program library file being used in this compilation.

ftn-714 crayftn: WARNING in command line

The "noomp" command has been overridden by the "omp" command.

ftn-714 crayftn: WARNING in command line

The "noomp" command has been overridden by the "omp" command.

fcm_internal compile failed (256)
# Time taken: 1 s⇒ ftn -o cosp_types_mod.o -I/home/n02/n02/earhg/um/xmmll/umatmos/inc -I/home/n02/n02/earhg/um/xmmll/baserepos/JULES/inc -I/home/n02/n02/earhg/um/xmmll/baserepos/UMATMOS/inc -e m -h noomp -s real64 -s integer64 -hflex_mp=intolerant -I /work/n02/n02/hum/gcom/cce8.3.7/gcom5.1/archer_cce_mpp/inc -h omp -c /home/n02/n02/earhg/um/xmmll/umatmos/ppsrc/UM/atmosphere/COSP/cosp_types_mod.f90
gmake: * [cosp_types_mod.o] Error 1
gmake:
* Waiting for unfinished jobs….

Change History (5)

comment:1 Changed 3 years ago by ros

Hi,

Please change permission on your ARCHER /home and /work space so that we can read them.

chmod -R g+rX /home/n02/n02/<your-username>
chmod -R g+rX /work/n02/n02/<your-username>

Cheers,
Ros.

comment:2 Changed 3 years ago by earhg

Sorry, that's done now. Hamish

comment:3 Changed 3 years ago by ros

  • Cc luke.abraham@… added
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Hamish,

You should switch off the handedit ~ukca/hand_edits/VN8.4/manual_comp_ARCHER.ed. This was just for UKCA training course to avoid queueing. The job will then compile automatically in the serial queue.

I also notice you have the handedit ~grenville/umui_jobs/hand_edits/remove_loadcomp.ed switched on. This removes the call to our module loading script which sets up the correct modules for compilation so that any changes made to the default modules by ARCHER don't cause problems. Do you know why you had this hand-edit included? Please try turning this hand-edit off too.

As you have been compiling with 2 different compiler versions you will need to make sure you do a full compile. Go to UMUI window FCM Configuration → Extract and Build directories and switch on Force Full Build.

Save, Process & Submit.

I've cc: Luke, in case there is something important regarding the remove_loadcomp.ed hand-edit.

Regards,
Ros.

comment:4 Changed 3 years ago by earhg

Hi Ros,
According to the .leave file, the job compiled fine after I made the changes you suggested. Thanks very much for your help! I don't know why the remove_loadcomp hand edit was included, and before your explanation I didn't know what it did, but hopefully its no longer necessary.
Best regards
Hamish

comment:5 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.