Opened 4 years ago

Closed 3 years ago

#1837 closed help (completed)

Getting traceback

Reported by: simon.tett Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.8

Description

HI,

my UM run has crashed… How do I find out where it has crashed i.e. get a traceback?

Simon

Change History (3)

comment:1 Changed 4 years ago by simon.tett

Solved this:
see ATP_ENABLED to 1 in script inserts.

Is there any harm in leaving this set if doing long runs?

comment:2 Changed 4 years ago by simon.tett

and now I am failing to get traceback:
*
UM Executable : /work/n02/n02/stett2/um/xlwts/bin/xlwts.exec
*

mkdir: cannot create directory `/nerc': Read-only file system
Application 20971790 is crashing. ATP analysis proceeding…
atpFrontend.exe: main: retrieveRawMBT:: recv of BT_HERE_IS_BACKTRACE failed

atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
_pmiu_daemon(SIGCHLD): [NID 04576] [c7-2c2s8n0] [Tue Mar 22 09:58:36 2016] PE RANK 30 exit signal Segmentation fault
atpAppSigHandler timed out waiting for shutdown. Re-raising signal.
[NID 04576] 2016-03-22 09:58:36 Apid 20971790: initiated application termination
ls: cannot access /nerc/n02/n02/stett2/archive/xlwts: No such file or directory
diff: /work/n02/n02/stett2/tmp/tmp.mom2.23599/xlwts.xhist: No such file or directory
qsexecute: Copying /work/n02/n02/stett2/um/xlwts/xlwts.thist to backup thist file /work/n02/n02/stett2/um/xlwts/xlwts.thist_keep
xlwts: Run failed

I introduced a flush(6) into my code to get all write statement output into the log files. Is this the cause of the traceback failure?

comment:3 Changed 3 years ago by ros

  • Resolution set to completed
  • Status changed from new to closed

Ticket coupled with #1868

Note: See TracTickets for help on using tickets.