Opened 5 years ago

Closed 5 years ago

#1854 closed help (fixed)

fcm make problem on ARCHER

Reported by: cthomas Owned by: ros
Component: FCM Keywords: ssh-agent PUMA
Cc: Platform: ARCHER
UM Version:

Description

Hi,

I am using a Rose suite to compile NEMO on ARCHER, submitting from Puma. Currently the fcm_make_nemo step, which copies files from the puma repository to a local directory, is failing. I am sure this worked previously (~Dec 2015), since I have binaries that were compiled successfully, and I haven't changed anything since then. I think I have set up the ssh-agent properly, but maybe something changed with the Puma upgrade. I can certainly log into ARCHER without a password, anyway.

This is job.err:

[FAIL] cmthomas@login.archer.ac.uk:cylc-run/puma-aa280/share/fcm_make_nemo: cannot create mirror target
[FAIL] ssh -n -oBatchMode=yes cmthomas@login.archer.ac.uk pwd # rc=255
[FAIL] --------------------------------------------------------------------------------
[FAIL] This is a private computing facility. Access to this service is limited to those
[FAIL] who have been granted access by the operating service provider on behalf of the
[FAIL] contracting authority and use is restricted to the purposes for which access was
[FAIL] granted. All access and usage are governed by the terms and conditions of access
[FAIL] agreed to by all registered users and are thus subject to the provisions of the
[FAIL] Computer Misuse Act, 1990 under which unauthorised use is a criminal offence.
[FAIL]
[FAIL] If you are not authorised to use this service you must disconnect immediately.
[FAIL] --------------------------------------------------------------------------------
[FAIL]
[FAIL] Permission denied (publickey,keyboard-interactive).^M

[FAIL] fcm make -f /home/cthomas/cylc-run/puma-aa280/work/20090101T0000Z/fcm_make_nemo/fcm-make.cfg -C /home/cthomas/cylc-run/puma-aa280/share/fcm_make_nemo -j 4 -vvv mirror.target=cmthoma\
s@login.archer.ac.uk:cylc-run/puma-aa280/share/fcm_make_nemo mirror.prop{config-file.name}=2 # return-code=2
Received signal ERR
cylc (scheduler - 2016-04-13T14:26:33Z): CRITICAL Task job script received signal ERR at 2016-04-13T14:26:33Z
cylc (scheduler - 2016-04-13T14:26:33Z): CRITICAL fcm_make_nemo.20090101T0000Z failed at 2016-04-13T14:26:33Z

The 'permission denied' message is suspicious. It looks like the script can't create the share/fcm_make_nemo directory. Is there something I need to tweak to fix this? If you need any more information about the suite or fcm options please let me know.

Thanks,
Chris

Change History (7)

comment:1 Changed 5 years ago by cthomas

  • Component changed from UM Model to FCM

comment:2 Changed 5 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Chris,

Can you please double check that you can login from PUMA to ARCHER without being prompted for either a password or passphrase.

ssh -n -oBatchMode=yes cmthomas@login.archer.ac.uk

The following line indicates that it is failing to login to ARCHER successfully with your ssh key.

[FAIL] Permission denied (publickey,keyboard-interactive)

Cheers,
Ros.

comment:3 Changed 5 years ago by cthomas

Hi Ros,

That ssh command works if I do this first:

eval `ssh-agent -s`
ssh-add

entering my password when required. I am not sure if that's the recommended method, however.

Thanks,
Chris

comment:4 Changed 5 years ago by ros

Hi Chris,

You shouldn't need to do the eval ssh-agent -s line if you have things set up correctly.

You will need to run the ssh-add command after every PUMA reboot and on occasions in between when the ssh-agent decides to die to re-attach the key to your agent.

We have some FAQs here which should help: http://cms.ncas.ac.uk/wiki/FAQ_T4

Regards,
Ros.

comment:5 Changed 5 years ago by cthomas

Hi Ros,

I can confirm that just using ssh-add (instead of both lines) fixed it.
Many thanks,
Chris

comment:6 Changed 5 years ago by ros

  • Keywords ssh-agent PUMA added; NEMO, fcm, ARCHER, Puma, Rose removed
  • UM Version <select version> deleted

Thanks for letting us know.

Cheers,
Ros.

comment:7 Changed 5 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.