Opened 3 years ago

Closed 3 years ago

#1875 closed help (fixed)

Insufficient space in Bsend buffer

Reported by: kz821407 Owned by: um_support
Component: UM Model Keywords: idealised
Cc: Platform: ARCHER
UM Version: 8.6

Description

Hi,

I am running an idealised flow over a mountain simulation and I am currently getting the error below.

I have ran successfully with a mountain height of 1.5km and wind speed of 2m/s but when I come to lower the mountain height the model falls over and the error occurs.


Random Perturbations

———————————

An error occured inside the MPI library during an operation
on the communicator: model
MPI_COMMUNICATOR= -1006632960 MPI_ERROR_CODE= 805949441 aborting…
Invalid buffer pointer, error stack:
MPI_Bsend(192)…….: MPI_Bsend(buf=0x7ffffc34a380, count=6554112, MPI_BYTE, dest=6, tag=106, comm=0xc4000000) failed
MPIR_Bsend_isend(347): Insufficient space in Bsend buffer; requested 6554112; total buffer size is 32000000
0+1 records in
0+1 records out
112684 bytes (113 kB) copied, 0.00261916 s, 43.0 MB/s
*

Job ended at : Fri May 6 16:26:02 BST 2016


*

The job is xmnqa on the umui and the leave file can be found here on Archer: /home/n02/n02/kz821407/output/xmqna000.xmqna.d16126.t065730.leave

Hope you can help as I really do not understand why it wont work.

I have also ran both mountain heights successfully with a wind speed of 10m/s.

Regards,
Carly

Change History (6)

comment:1 Changed 3 years ago by grenville

Carly

Which job worked with mountain height of 1.5km and wind speed of 2m/s?

Grenville

comment:2 Changed 3 years ago by kz821407

Hi Grenville,

It was job nmqnb which worked for 1.5km and 2m/s winds

Carly

comment:3 Changed 3 years ago by grenville

Carly

xmqna is on 28x36 processors
xmqnb is on 12x24 processors

That will affect communications.

Grenville

comment:4 Changed 3 years ago by kz821407

Yes I know I have more processors on xmqna but this is because I was trying to increase the number to see if it fixed the problem.

It was initially the same number as xmqnb but I got the same error as above.

Carly

comment:5 Changed 3 years ago by kz821407

Hi Grenville,

I deleted the job from Archer and Puma and started again the UMUI and it appears to have worked this time.

Thanks,
Carly

comment:6 Changed 3 years ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed

OK - thanks.

Note: See TracTickets for help on using tickets.