Opened 3 years ago

Closed 3 years ago

#1881 closed help (fixed)

problems with mosrs-cache-password & gpg-agent on PUMA

Reported by: luke Owned by: um_support
Component: PUMA Keywords: mosrs,gpg-agent
Cc: Platform: PUMA
UM Version: <select version>

Description

I am trying to copy a Rose suite on PUMA, and I am being repeatedly asked for my MOSRS password. When I try to run mosrs-cache-password I get the following errors:

[12:09:06 luke@puma ~]$ mosrs-cache-password
gpg-agent: no process killed
Error: gpg-agent not working
Run "mosrs-cache-password" to try caching your password again
Exit 1

Can I ask for suggestions as to what to do?

Many thanks,
Luke

Change History (2)

comment:1 Changed 3 years ago by ros

Hi Luke,

You appear to have commented out the section in your ~/.profile which starts up the gpg-agent.

[[ "$-" != *i* ]] && return # Stop here if not running interactively
. mosrs-setup-gpg-agent

Try running . mosrs-setup-gpg-agent on the command line and see if that works. If it does then please uncomment the lines in your .profile.

This will mean it prompts for your MOSRS password the first time you log in to PUMA each day - but if you aren't going to be using MOSRS just hit return. You can then run moses-cache-password as you have done above if you find you then need it.

Cheers,
Ros.

comment:2 Changed 3 years ago by luke

  • Resolution set to fixed
  • Status changed from new to closed

Hi Ros,

Thanks! That seems to work - silly me!

Regards,
Luke

Note: See TracTickets for help on using tickets.