Opened 3 years ago

Closed 3 years ago

#1888 closed help (completed)

Task state not changing on exvmscylc

Reported by: ros Owned by: ros
Component: Rose Keywords:
Cc: Platform: MONSooN
UM Version: 10.3

Description

Ros

Is this one you can help with please?

Regards

Katie

From: Ian Ashpole
Sent: 01 June 2016 15:39
To: Monsoon
Subject: task state not chaning on exvmscylc

Hi,

Apologies if I haven’t directed this email to the correct person. I’m currently experiencing difficulties getting a job to run because the state of one of the tasks seems to be stuck at ‘submitted’ on exvmscylc, even though I can see that the task is actually running on xcm (using qstat or qstat_snapshot). I’ve tried re-running but the same problem occurs. Is there a fix that you know for this? I’ve never had a problem like this before.

Thanks for any help you can give me.

All the best,

Ian


Change History (5)

comment:1 Changed 3 years ago by ros

Hi Ian,

Can you give me the details of the suite that exhibits this problem please and I'll take a look.

I've not seen this problem on exvmscylc before.

I assume you have tried polling the task to see if that will cause cylc to update?

Cheers,
Ros.

comment:2 Changed 3 years ago by ros

Hi Ros,

The suite id is u-ad849. Polling doesn’t change things, unfortunately. The task it gets stuck in is install_ancil.

Thanks very much for your help,

Ian

comment:3 Changed 3 years ago by ros

Hi Ian,

I've just tried using different versions of Rose/Cylc which then fixes the problem for me.

Could you try changing to a different version and see if that fixes it for you too?

exvmsrose$ export CYLC_VERSION=next
exvmsrose$ export ROSE_VERSION=next
exvmsrose$ rose suite-run

Do check that it's picked up the new versions…..
In the submission output to the screen or pop up box if you're running via the GUI you should see lines like:

[INFO] export CYLC_VERSION=6.10.2
[INFO] export ROSE_ORIG_HOST=exvmsrose.monsoon-metoffice.co.uk
[INFO] export ROSE_VERSION=2016.05.1

Let me know if that fixes it for you and I'll report it to the Met Office.

Cheers,
Ros.

comment:4 Changed 3 years ago by ros

Hi Ros,

Thanks for the suggestions. I’m just re-running the job now. The Cylc and rose versions match what you put below in the submission output to the screen, and the install_ancil task succeeded (it took 7 seconds…) so fingers crossed that’s the problem solved. J

I’ll get back to you if it falls down again, but looks like it’s ok now.

Ian

comment:5 Changed 3 years ago by ros

  • Resolution set to completed
  • Status changed from new to closed

This problem was part of general problem on MONSooN which the Metomi & HPC teams fixed.

Note: See TracTickets for help on using tickets.