Opened 4 years ago

Closed 4 years ago

#1892 closed help (fixed)

Rose test suite not running

Reported by: mrusso Owned by: ros
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 10.4

Description

Hello,
I've just started using Rose and I have a problem running the test suite from the tutorial.

I have an account on the MOSRS repository and followed the instructions to configure subversion access and cache the password.
I've chosen u-aa774@11173 to run on Archer as suggested here (http://cms.ncas.ac.uk/wiki/RoseCylc)
I have taken a copy of the above, changed HPC_user to my archer username 'mariar' and HPC_ACCOUNT to 'n02-chem' and saved the changes.
When I run the suite I get the following error message:
RosePopenError? ssh -oBatchMode=yes mariar@… bash —login -c \'ROSE_VERSION=2016.03.0\ rose\ suite-run\ -v\ -v\ —name=u-ad997\ —run=run\ —remote=uuid=689cb62e-a608-42c2-827d-0a2792645622,root-dir=$DATADIR\'# return-code=255, stderr=
This is a private computer facility ……
……
…..
Permission denied (publickey,keyboard-interactive)

Any help would be greatly appreciated!
Many thanks in advance,
Maria

Change History (3)

comment:1 Changed 4 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Maria,

You need to make sure your ssh-agent is set up so you can login from PUMA to ARCHER without being prompted for a password.

From the error message above it looks like your ssh-agent may not be running or you just need to run ssh-add.

Regards,
Ros.

comment:2 Changed 4 years ago by mrusso

Thanks Ros,
I had forgotten you need to run ssh-add (just come back from maternity leave).
It does run now.
many thanks again,
Maria

comment:3 Changed 4 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.