Opened 3 years ago

Closed 3 years ago

#1900 closed help (fixed)

UM run will only start in September??

Reported by: IanAshpole Owned by: willie
Component: UM Model Keywords:
Cc: Platform: MONSooN
UM Version: 10.3

Description

I have what is hopefully a quite trivial problem. Basically, I have a suite (u-ae284) that I want to run from the month of May. However, when I specify any month other than September (month ’09’) in:

Suite conf → Run Initialisation and Cycling → Model basis time

The model crashes at the ATMOS task with the following error message:
?  Error code: 1
?  Error from routine: INITTIME
?  Error message: INITTIME: Atmosphere basis time mismatch

Do you know of any way around this?

Thanks and best wishes,

Ian

Change History (15)

comment:1 Changed 3 years ago by ros

Hi Ian,

The Model Basis Time and datestamp in the start dump must be the same.

Do you really wish to run from May using September start data? If so let me know and I'll dig out the details on how to change the date in the dump file.

Cheers,
Ros.

comment:2 Changed 3 years ago by ros

Hi Ros,

Ok, that makes sense – thanks!

Basically what I want to do is run the model for 10 summer seasons (2001-2012). As my only interest is the summer months I didn’t think it would be worth running for the other seasons. So I guess my question becomes: Is there a way to do this? I think it probably doesn’t make sense running from May using September start data – so is there anywhere I can find start dumps for May?

Thanks,
Ian

comment:3 Changed 3 years ago by ros

Hi Ian,

Yes you can do this.

I've copied Willie in who should be able to help you get hold of startdumps for May for each year.
You could then set up a series of suites to each run for one summer season.

Cheers,
Ros.

comment:4 Changed 3 years ago by ros

  • Owner changed from um_support to willie
  • Reporter changed from ros to IanAshpole
  • Status changed from new to assigned

comment:5 Changed 3 years ago by willie

The Met Office start dumps only go back to 2006. I can get ECMWF start dumps back to 2001 in GRIB format. I would suggest getting 01 May 0Z for each year in this format - so twelve files in all.

:
Your data is now ready on MONSooN in /projects/umadmin/wmcgin/data_xfer.
:
suite is now crashing at the recon task. Scanning the job.err file (my rose suite id is u-ae284), it looks like the task is running out of time:

⇒> PBS: job killed: walltime 927 exceeded limit 900

As the model never used to fall over at this stage, I am guessing it is because of the new Startdump files. Do you know how/where to request more time for this task in my rose suite?

comment:6 Changed 3 years ago by willie

Hi Ian,

If you double click on your suite in rosie, then expand um > namelist > Reconfig > General, you will need to specify ainitial as the GRIB file and click the GRIB button.

Regards

Willie

comment:7 Changed 3 years ago by IanAshpole

Hi Willie,
I have done both of these things, but the suite is still crashing at the recon phase with the walltime limit posted above. Any idea how to progress from here?
Best wishes,
Ian

comment:8 Changed 3 years ago by willie

Hi Ian,

Revision 14328 of your suite has ainitial set to

'/projects/ukca-read/nbellou/ab770a.da20010901_00'

which is a UM file?

Willie

comment:9 Changed 3 years ago by IanAshpole

Hi Willie,
apologies, i hadn't committed the change. I have just committed revision 14643 which should hopefully reflect the changes.

Ian

comment:10 Changed 3 years ago by willie

Hi Ian,

If you expand suite conf and click on it, under other files > site >MONSooN.rc. Double click on the rc file and half way down there is a section RCF_RESOURCE where the time is specified as "-l walltime=00:15:00".

I hope that helps

Willie

comment:11 Changed 3 years ago by IanAshpole

Hi Willie,
Thanks very much for the direction - i have increased this value and will report back with the outcome.

Best,
Ian

comment:12 Changed 3 years ago by IanAshpole

Hi Willie,
The suite is still crashing. I have increased the walltime under RCF_RESOURCE to 3 hours yet it is still crashing at the recon task with the error message:

⇒> PBS: job killed: walltime 10841 exceeded limit 10800

Any ideas?

Thanks,
Ian

comment:13 Changed 3 years ago by willie

Hi Ian,

It shouldn't take that long. I suspect that the reconfiguration is failing - can you look in the PE output and see? It is likely that there are missing fields i.e. the UM is expecting a field in the input which isn't there because it is a GRIB file. You just have to specify where the field is coming from or switch the science off if it is not needed. You can specify an ancillary file as a source for some.

Willie

comment:14 Changed 3 years ago by willie

Hi Ian, Is this still a problem?

Willie

comment:15 Changed 3 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.