Opened 3 years ago

Closed 3 years ago

#1931 closed help (fixed)

puma is not working - I can't submit jobs

Reported by: im13009 Owned by: ros
Component: PUMA Keywords:
Cc: Platform: ARCHER
UM Version: 4.5

Description

Hi,

I can't submit any job through puma. Every time that I type the command:

puma:/home/im13009 $ ssh agent-bash

,I get the error message:

ssh: Could not resolve hostname agent-bash: Name or service not known

If I access the puma window (umui &) and I submit a job (entering my passphrase), I get the following error message, if you get a permission denied error, your user name is wrong or you entered the wrong password on machine login.arhcer.ac.uk. This is strange because I have not changed my username or password. I have been using the same password and username for almost a year and this is the first time I'm having trouble.

Many thanks,
Irene.

Attachments (1)

images.docx (305.4 KB) - added by im13009 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by ros

Hi Irene,

Please try re-attaching your ssh-key to your agent by running:

puma$ ssh-add

If you get a message saying Could not open a connection to your authentication agent please follow the instructions on our FAQ: http://cms.ncas.ac.uk/wiki/FAQ_T4_F5

You should hopefully then be able to login from PUMA to ARCHER without being prompted for either a password or passphrase.

Regards,
Ros.

Last edited 3 years ago by ros (previous) (diff)

comment:2 Changed 3 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

comment:3 Changed 3 years ago by im13009

Hi,
I have type the following commands and I did't get any error.
puma:/home/im13009 $ ssh-agent bash
puma:/home/im13009 $ ssh-add
Enter passphrase for /home/im13009/.ssh/id_rsa:
Identity added: /home/im13009/.ssh/id_rsa (/home/im13009/.ssh/id_rsa)

However, I still have the same problem. I can't submit the jobs. When I access the puma window (umui &) and I submit a job (this time I don't need to enter the passphrase), I get same following error message: your user name is wrong or you entered the wrong password on machine login.arhcer.ac.uk.

Many thanks,

Irene.

comment:4 Changed 3 years ago by ros

Hi Irene,

Please don't start your ssh-agent using ssh-agent bash as this starts up the agent in a new instance of the shell which can cause problems or simply won't work.

The recommended way to start up your agent is by calling a setup script in your ~/.profile. Please add the following lines to your ~/.profile on PUMA

# ssh-agent setup
. $HOME/.ssh/ssh-setup

Then copy the ssh-setup script to your directory:

puma$ cp ~um/um-training/setup/ssh-setup ~/.ssh/ssh-setup

Log out of PUMA and back in again, you will hopefully see a message "Initialising new SSH agent…"

Then run ssh-add

You may need to follow the instructions above if you get a "Could not open a connection.." message.

Once that's set up please try logging into ARCHER and check that you are not prompted for either a password or passphrase.

Regards,
Ros.

Changed 3 years ago by im13009

comment:5 Changed 3 years ago by im13009

Hi Ros,

Thank you for your prompt response.

I have followed your instructions. I have added the following lines to my .profile on PUMA.

# ssh-agent setup
. $HOME/.ssh/ssh-setup

Then I have copied the ssh-setup script to my directory. I have logged out of PUMA and back in again.

When I run ssh-add, I need to enter my passphrase. Then I can log into ARCHER and I don't need to enter any password or passphrase.

However, I still have the same problem when submitting a job. When I open umui and use the submit button, I get the same error message: if you get a permission denied error, your user name is wrong or you entered the wrong password on machine login.arhcer.ac.uk. Attached you can find a screenshot.

I use PUMA to submit jobs to two different machines, ARCHER and Bluecrsytal (Bristol). The .profile I have on PUMA is a copy of the profile of my Bristol supervisor. This may be the cause of the problem. You can find my .profile on puma:/home/im13009/.profile

Many thanks,
Irene.

comment:6 Changed 3 years ago by ros

Hi Irene,

Thanks for the screenshot, puts things in context; that message is output for every run only to alert you if you do get a permission denied which you're not. The output to the UMUI window is as I would expect and then just stops, this is a symptom of running out of disk space on /home on ARCHER. Along with all the files under the umui_runs directory e.g. /home/n02/n02/im13009/umui_runs/tecin-216143337 being zero length.

You have 4.8Gb of .leave files under /home/n02/n02/im13009/um/umui_out. If you clear some of these out your job will then submit successfully.

Regards,
Ros.

comment:7 Changed 3 years ago by im13009

Thank you Ros. Problem solved!

comment:8 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.