Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1935 closed help (fixed)

Unable to copy u- suite

Reported by: mattjbr123 Owned by: um_support
Component: Rose Keywords: rosie, copy, svn
Cc: Platform: MONSooN
UM Version:

Description

Hi,

I'm attempting to copy suite u-ad131 from the MOSRS rosie-u repo so that I can make the necessary changes to get it working on Monsoon for me. However whenever I try and copy it through either the rosie go GUI or rosie copy command, svn throws up the following error:

[FAIL] svn commit -q -m u-af402:\ new\ suite,\ a\ copy\ of\ u-ad131/trunk@10853 /var/tmp/tmpKuAsBR/work # return-code=1, stderr=
[FAIL] svn: E165001: Commit failed (details follow):
[FAIL] svn: E165001: Commit blocked by pre-commit hook (exit code 1) with output:
[FAIL] 2016-08-04T11:42:51Z+ 17379-dol by mattbrown
[FAIL] A   a/f/4/0/2/
[FAIL] A   a/f/4/0/2/trunk/
[FAIL] U   a/f/4/0/2/trunk/rose-suite.info
[FAIL] [FAIL] NO SUCH USER: U   a/f/4/0/2/trunk/rose-suite.info: owner=MattBrown

I have followed all the password caching instructions and checked the setup is exactly as specified there, and can't find anything wrong.

Any ideas?

Cheers,
Matt

Change History (8)

comment:1 Changed 3 years ago by mattjbr123

Okay got it to work in the GUI by changing owner to mattbrown as opposed to MattBrown?.

comment:2 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
  • UM Version <select version> deleted

Hi Matt,

I was just going to say that to you!

You do appear to have your .subversion/servers file setup with the correct username so it should populate this field automatically for you.

Regards,
Ros.

comment:3 Changed 3 years ago by mattjbr123

Is there any reason why it populates the owner field with MattBrown? rather than mattbrown? It's no big deal, just curious!

comment:4 Changed 3 years ago by ros

Hi Matt,

It is supposed to pick it up from your ~.subversion/servers file. Did you at any point have MattBrown in that file? It might have cached it somewhere and still be using that - you could try looking if there's anything under the .subversion/auth directory. I don't have permission to read it so can't check.

Cheers,
Ros.

comment:5 Changed 3 years ago by mattjbr123

There's nothing in the .subversion/auth/svn.{username,ssl.server,ssl.client-passphrase} directories, and in the svn.simple directory there's the following, but the usernames appear to be correct (one for MOSRS and one for puma).

I don't think I ever had MattBrown? in the servers file, although in the .subversion/servers~ file it only has the puma username, if that means something?

 more .subversion/auth/svn.simple/b68a6780803094a2aaf7cfe1de55c9af
K 8
passtype
V 6
simple
K 8
password
V 0

K 15
svn:realmstring
V 65
<svn://puma.nerc.ac.uk:3690> 5a4f76ba-60e8-11e4-9762-edf9b8095a3c
K 8
username
V 10
mattjbr123
END

and

 more .subversion/auth/svn.simple/2be6a67d04b1c8c6d879daafa52fd762
K 8
passtype
V 9
gpg-agent
K 15
svn:realmstring
V 51
<https://code.metoffice.gov.uk:443> Met Office Code
K 8
username
V 9
mattbrown
END

comment:6 Changed 3 years ago by mattjbr123

When I cache my password upon login, it also appears to be using MattBrown?:

Met Office Science Repository Service password:
Subversion password cached
https://code.metoffice.gov.uk/rosie/u/hello: Hello MattBrown
Rosie password cached

comment:7 Changed 3 years ago by mattjbr123

Stumbled upon the answer by chance:

In .metomi/rose.conf I had

[rosie-id]
prefix-username.u=MattBrown
prefixes-ws-default=puma u

Now that it's mattbrown it's fixed :)

No idea where that came from…

Last edited 3 years ago by mattjbr123 (previous) (diff)

comment:8 Changed 3 years ago by ros

Great. Well done.

Thanks for letting us know.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.