Opened 3 years ago

Closed 3 years ago

#1948 closed help (fixed)

Routine generating error: Atm_Step after 30 successful model years

Reported by: ih280 Owned by: willie
Component: UM Model Keywords: STASH
Cc: Platform: MONSooN
UM Version: 7.3

Description

Hello,
I have three model runs (xltli, xltlj, xmveb) that are all crashing at the same timestep (814473) with an identical error message.
The corresponding leave files are:

/home/inhei/output/xmveb025.xmveb.d16219.t134201.leave
/home/inhei/output/xltli025.xltli.d16200.t091417.leave
/home/inhei/output/xltlj025.xltlj.d16200.t073250.leave

 *********************************************************************************
 UM ERROR (Model aborting) :
 Routine generating error: Atm_Step
 Error code:  4
 Error message: 
STWORK   : NO. OF FIELDS EXCEEDS RESERVED HEADERS                               
9<8E><E3><98>0?k@^Z^@^@^@<<FE>j@^@^@^@ e<D8>j@r^\<C7>^Q<F0><A5>j@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@X^@^B^@^@^@^@^C^M^@^@^@^C^@^D^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^A^@^@^@^@^@^@^@^L^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^F^@^@^@^@^@^@^@^L^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^L^@^@^@^@^@^@^@H^@^@^@^@^@^@^@VUU<95><9F><E4>h@
        <87>S
^@<94><D1>@@^@^@^@^@^@^@^@
 *********************************************************************************

In addition to the error message, the last two dumpfiles are emtpy. (I deleted the corresponding files for xltli and xltij).

/projects/ukca-cam/inhei/xmveb/xmveba.dan2410
/projects/ukca-cam/inhei/xmveb/xmveba.dan2510

Each job has completed 30 years successfully before this timestep. The data is automatically archived and as such previous dumps are deleted upon successful archiving. When re-running the jobs from a previous dump (10 years earlier as this was the last one saved) the model goes past the date that caused the problem before (xltlk and xltll).

Any ideas as to why this is happening would be greatly appreciated.
Best wishes,
Ines

Change History (6)

comment:1 Changed 3 years ago by willie

Hi Ines,

The response to #1817 is relevant here I think. See

Please see UKCA tutorial 3 ('What is STASH?') here:

http://www.ukca.ac.uk/wiki/index.php/UKCA_Chemistry_and_Aerosol_Tutorial_3

specifically the solution to Task 3.1:

http://www.ukca.ac.uk/wiki/index.php/Solution_to_UKCA_Chemistry_and_Aerosol_Tutorial_3_Task_3.1

Either of the two options would work, ….

Willie

comment:2 Changed 3 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

comment:3 Changed 3 years ago by ih280

Dear Willie,
Thank you for your reply. However, I don't quite understand what I need to change as the error comes from

STASH : Error processing diagnostic section 0 , item 24 , code 4

While the "Verify diagnostics" in xmveb only gives the following warnings:

Warning: 
You may exceed the maximum number of PP fields per file
	      
Estimated number of PP files to be written:

8794 fields in Climate mean Period_1
8794 fields in Climate mean Period_2
8794 fields in Climate mean Period_3
8794 fields in Climate mean Period_4

Maximum allowed is 4096 fields per stream.

and the Tutorial states that one does not need to worry about the Climate Mean Periods (and my numbers are smaller than those stated in the Tutorial).

Best wishes,
Ines

comment:4 Changed 3 years ago by willie

  • Keywords STASH added

Hi Ines,

Maybe the issue is that the run is for 50 years, but many of the diagnostics for UPD/63 only go up to 30 years, so the only item being output then is 0,24 every three hours. But in Post Processing > Initial, the stream 63 ends at 10800 days = 30 years, so you're trying to write to a file that's closed?

Other issues are that you have a lot of STASH switched on which is not available in this version ( it has X under I+P+A) - not a run time problem, but it does clutter the STASH verification. Also in section 6 the items there have inconsistent domain profiles which could cause run time errors.

Willie

comment:5 Changed 3 years ago by ih280

Hi Willie,

Thank you for these information - hopefully this will solve the issue. I will change those STASH items in my future runs and will get back to you in case the problem is not solved.

Again, thank you!
Best wishes,
Ines

comment:6 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.