Opened 3 years ago

Closed 3 years ago

#1954 closed help (fixed)

problem with accumulated fields / time profile?

Reported by: anmcr Owned by: um_support
Component: UM Mesoscale Keywords: accumulated fields
Cc: Platform: MONSooN
UM Version: 10.2

Description

Hi,

I'm having a problem correctly archiving accumulated fields in the UM (Stu Webster's nested suite on MONSooN). I'm completely stuck having tried to fix it myself (checking out other jobs and making sure that the time profile matched; outputting the accumulated fields as a separate output stream) as well as asking around other people.

The problem is that the timestamp on the accumulated fields does not match that of the corresponding instantaneous fields. For example, the attached screen shot shows output from T+12 h. While the instantaneous 10 m wind field correctly shows this time, the LW increment which has been accumulated for 1 hr shows a time of 6 h into the run. I have wondered whether it is just a labelling / header error? The job is u-af801.

Thanks

Andrew

Attachments (3)

accumulated_fields.PNG (378.7 KB) - added by anmcr 3 years ago.
accumulated field (LW increment) and instantaneous field (10 m wind) - different time stamps but outputed in the same file
for-jeff-1.PNG (125.8 KB) - added by anmcr 3 years ago.
time profile for accumulated fields #1
for-jeff-2.PNG (112.7 KB) - added by anmcr 3 years ago.
time profile for accumulated fields #2

Download all attachments as: .zip

Change History (26)

Changed 3 years ago by anmcr

accumulated field (LW increment) and instantaneous field (10 m wind) - different time stamps but outputed in the same file

comment:1 Changed 3 years ago by jeff

Hi Andrew

Can you point me to the file(s) which contain the data used in those plots. Thanks.

Jeff.

comment:2 Changed 3 years ago by anmcr

Hi Jeff,

The files are at /home/amworr/cylc-run/u-af801/share/cycle/20110127T0000Z/Peninsula/km4p0/ctrl/um/umnsaa_pd*.

Note that they didn't archive in MASS for some reason. That could either be because of a header error, or more likely I made a mistake with the output stream. I tried everything to get this to work, including archiving the accumulated fields to their own output.

Thank you for looking at this.

Best wishes,

Andrew

comment:3 Changed 3 years ago by anmcr

Hi Jeff,

I should have said that this in on MONSOooN.

Andrew

comment:4 Changed 3 years ago by jeff

Hi Andrew

I think the problem is how xconv deals with time mean and accumulated fields. For these cases xconv will select the middle of the time range as its time point, so these will not match up with instantaneous fields.

In your original query did you mean the field has been accumulated for 12 hours?

Jeff.

comment:5 Changed 3 years ago by anmcr

Hi Jeff,

No, the fields were accumulated for 1 hour.

Andrew

comment:6 Changed 3 years ago by jeff

In that case you will need to point me to the file which you used to generate those plots because the files given above are not even the same resolution.

comment:7 Changed 3 years ago by anmcr

Hi Jeff,

Sorry, but I don't quite understand.

The files I pointed you to were the output from a nested model run. The model had 3 grid spacings of 4, 1.5 and 0.5 km. Files from each of these domains are situated at /home/amworr/cylc-run/u-af801/share/cycle/20110127T0000Z/Peninsula/ …. The model job is u-af801, which is setup using ROSE.

Andrew

Changed 3 years ago by anmcr

time profile for accumulated fields #1

Changed 3 years ago by anmcr

time profile for accumulated fields #2

comment:8 Changed 3 years ago by anmcr

jeff,

attached are screen shots if the time profile i used for accumulated fields.

andrew

comment:9 Changed 3 years ago by jeff

Hi Andrew

Ok I understand what you are doing now, the fields are being accumulated at every time-step and output every hour. Therefore after 12 hours run-time you will have accumulated 12 hours of data and as I said above xconv will select the middle of the time range as its time point, i.e. 6 hours. Similarly after say 20 hours you you will have accumulated 20 hours of data and xconv will have 10 hours as its time point.

Of course this is just what xconv makes of the data and has nothing to with why the UM archiving doesn't work.

Jeff.

comment:10 Changed 3 years ago by anmcr

Hi Jeff,

Thanks for getting to the bottom of this.

So is the problem with the way I set up the time profile? Or with the output settings? I want to output 1 hour of accumulated data, every hour, ie after outputting 1 hour of accumulated data the output is reset and the accumulation starts from zero again. I hope I have explained this sufficiently clearly?

Could you please advise me on what changes I need to make in ROSE to achieve this?

Many thanks,

Andrew

comment:11 Changed 3 years ago by jeff

Hi Andrew

To do this you need to change your time profile T1HR_acc. You have set intv to -1 this means to accumulate the field indefinitely, what you want to do is reset the accumulation every time you output the field. To do this the processing time needs to be the same as the output time, 1 hour in your case, so set intv=1. Hopefully this should do what you want.

By the way when I refer to output time I mean the output time as defined in the time profile.

Jeff.

comment:12 Changed 3 years ago by anmcr

Dear Jeff,

Great news that you have found out how to fix the problem. I set intv=1 and the accumulated fields now have the correct time.

However, they are now not being archived on MASS. The run fails in the 'archive' step with the error 'PP file has invalid date in field 122'. Therefore, as the fields are not being archived, they are still at /home/amworr/cylc-run/u-af801/share/cycle/20110127T0000Z/Peninsula/

Do you know why they are not being archived?

Thanks for your help,

Andrew

comment:13 Changed 3 years ago by anmcr

Dear Jeff,

I'm under a certain amount of pressure to complete these model runs for a paper resubmission. I therefore resubmitted the job for a different case study (despite the archiving problem not having been fixed).

However, the job failed at POLL > poller with what i think was a 'time out' error as numerous 'POLL ATTEMPT' were submitted without any of them being successful.

I looked up previous tickets and could not find this error.

I also resubmitted the job using 'rose suite-run —new', but the error persisted.

I would be grateful if you could advise.

thanks,

Andrew

comment:14 Changed 3 years ago by ros

Hi Andrew,

I'm not really sure what that poller app is doing. It looks like it's trying to test the success of previous tasks before running the main application and can be done automatically in the suite definition. In app/poller/bin/check_task_status there's a hard-wired path to a directory that doesn't exist on MONSooN. I guess this is the problem? You could try changing this in your rose suite to point to your cylc-run directory and see if that works. However, the path is a central location and is hidden from the GUI so makes me suspect that this app possibly shouldn't be run for user suites. Might be best to talk to Stu Webster…

Regards,
Ros.

comment:15 Changed 3 years ago by anmcr

Hi Ros,

Thanks for looking at this. I have run these sorts of jobs a number of times and never came across this error, or really been aware of the poller app.

Do you think that if i made a copy of the job then it would work?

Best wishes,

Andrew

comment:16 Changed 3 years ago by ros

Hi Andrew,

Ok. I think I might have figured out your problem looking at some of your other suites….

In u-af801 you are trying to run in "Follow operational suite" mode. This means "The nesting suite will use the specified operational model as a driving model. This is useful for running the nesting suite in real-time. A poller task holds the suite until the required driving model files are available."

So the poller app will never succeed on MONSooN as the operational driving data doesn't exist there and explains the hard-wired path I was talking about above. All your other suites that I've looked at are running in "Re-run from files on disk" mode. So if you change to this mode in suite.conf → jinja2:suite.rc → Driving model setup, that should stop the poller task running.

Regards,
Ros.

comment:17 Changed 3 years ago by anmcr

Dear Ros,

Thank you very much for spotting this. I was accessing ROSE from Kuala Lumpar using a very slow internet link, which made making changes to the job difficult. I can only think that in doing this I somehow accidently clicked on 'follow operational suite'. I'm afraid that once the job failed I didn't look through my job as I was under the impression that I had not made any changes from a previously working job.

Anyway, I've made the change and resubmitted the job.

Thank you again for spotting this.

Andrew

comment:18 Changed 3 years ago by anmcr

Dear Jeff,

I raised a problem I am having archiving files onto MASS a number of days ago. I've recopied what I wrote below. Are you able to advise?

Many thanks,

Andrew

However, they are now not being archived on MASS. The run fails in the 'archive' step with the error 'PP file has invalid date in field 122'. Therefore, as the fields are not being archived, they are still at /home/amworr/cylc-run/u-af801/share/cycle/20110127T0000Z/Peninsula/. Do you know why they are not being archived?

comment:19 Changed 3 years ago by jeff

Hi Andrew

There are no files in /home/amworr/cylc-run/u-af801, is there another file which has this error message?

Jeff.

comment:20 Changed 3 years ago by anmcr

Dear jeff,

u-af992, u-af995 and u-ag029 have all failed in 'archive' with this error and should still have their files avalable to view.

Best wishes,

Andrew

comment:21 Changed 3 years ago by jeff

Hi Andrew

I'm not sure why this doesn't work, I can't run moo so have no way of replicating the problem. Unless there is another CMS person with more knowledge of mass/moose/moo than me who can pick up this query, then I would suggest contacting the Met Office about this problem.

Jeff.

comment:22 Changed 3 years ago by anmcr

Dear Jeff,

Please close this ticket. I upgraded to vn10.4 and the archiving to MASS worked fine.

Thanks to you and Ross for your help.

Andrew

comment:23 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.