Opened 4 years ago

Closed 4 years ago

#1964 closed help (fixed)

netcdf module for UKCA job

Reported by: emxin Owned by: ros
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 7.3

Description

I started to run um-UKCA again (my last run was almost one year ago). when I submitted my job on puma, I got error message showning below:
CM_MAIN: Submit OK
umui_runs/xkqjq-245140651/SUBMIT[13]: .[9]: .[370]: .: line 72: PROMPT_COMMAND: is read only
ModuleCmd_Load.c(226):ERROR:105: Unable to locate a modulefile for 'netcdf'

I have tried updated the module on ARCHER machine (but not help). Can you tell me what I need to do?

Change History (5)

comment:1 follow-up: Changed 4 years ago by ros

  • Owner changed from um_support to ros
  • Platform set to ARCHER
  • Status changed from new to accepted

Hi,

Could you please give us permission to see your /home and /work directories on ARCHER.

chmod -R g+rX /home/n02/n02/emxin
chmod -R g+rX /work/n02/n02/emxin

Cheers,
Ros.

comment:2 Changed 4 years ago by emxin

I am changing the permission for you. it just takes some time to finish.
I just noticed that when I login to ARCHER, I have the following messages:
-bash: HISTCONTROL: readonly variable
-bash: PROMPT_COMMAND: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: HISTSIZE: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: PROMPT_COMMAND: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: HISTSIZE: readonly variable
ModuleCmd_Load.c(226):ERROR:105: Unable to locate a modulefile for 'netcdf'

comment:3 Changed 4 years ago by ros

Hi,

The problem is with your .profile. Please remove the line

module add netcdf

The UM will automatically load the correct module. For reference the module name has changed and should you need to load the netcdf module in the future, you will need to run

module load cray-netcdf

Cheers,
Ros.

comment:4 in reply to: ↑ 1 Changed 4 years ago by emxin

Replying to ros:

Hi,

Could you please give us permission to see your /home and /work directories on ARCHER.

chmod -R g+rX /home/n02/n02/emxin
chmod -R g+rX /work/n02/n02/emxin

Cheers,
Ros.

Hi Ros,

Thank you for your help!

Xin

comment:5 Changed 4 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
  • UM Version changed from <select version> to 7.3
Note: See TracTickets for help on using tickets.