Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1971 closed help (answered)

Can't get some triggers to work

Reported by: mattjbr123 Owned by: um_support
Component: Rose Keywords: triggering, trigger, metadata
Cc: Platform: MONSooN
UM Version:

Description

Hi,

I'm having trouble getting some of my metadata triggering working.
I have a variable in [jinja2:suite.rc] section of the rose-suite.conf file and I'd like it to trigger another variable in the same section. I've had no problem getting it to work in other namelists but this one is being stubborn!

Specifically, it involves the following three variables:

[jinja2:suite.rc=NENS]
ns          = Ensembles
compulsory  = false
help        =
title       = Number of ensemble members
type        = integer
sort-key    = 4

[jinja2:suite.rc=XENS]
ns          = Ensembles
compulsory  = false
help        =
title       = Individual ensemble members
help        = A range of members may be described using a hyphen.
type        = character
length      = 9999 
sort-key    = 4

[jinja2:suite.rc=RUN_ALL]
ns= Ensembles
compulsory= false
help=
title= Run all realisation members
type= boolean
sort-key= 3
trigger=jinja2:suite.rc=NENS: true;
         =jinja2:suite.rc=XENS: false;

So when RUN_ALL is set to true NENS should become available (and XENS trigger ignored) and when RUN_ALL is set to false XENS should be available (and NENS trigger ignored), if I have understood it correctly.

However when I change RUN_ALL in the rose edit GUI, no triggering happens, XENS and NENS stay exactly as they are.

What I suspect could be the issue is how rose edit deals with links in the metadata text. Clicking on the small settings icon to the left of RUN_ALL in the rose edit GUI and clicking info, in the trigger section only 'rc=NENS' and 'rc=XENS' appear as linked text (i.e. blue and underlined) when it should be the whole ID that is linked i.e. jinja2:suite.rc=NENS (picture attached)
I have looked at other triggers in my suite and none of them have dots ('.') in their IDs, and they are all linked properly and seem to work.

The suite is u-af404 and I am running on MONSooN with Rose version 2016.07.0

Attachments (1)

Screenshot_20160912_175426.png (1.9 MB) - added by mattjbr123 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by mattjbr123

comment:1 Changed 3 years ago by ros

Hi Matt,

The funny links in the info pop up are fine. This is the same for other suites with triggers in the "suite conf" section. Actually you'll also see it in the Testing window for your suite.

When you fire up the Rose edit GUI there is a "Flawed metadata warning". This is causing all the triggers in the "suite conf" section to be turned off. You need to fix these errors first.

3 problem(s) found in metadata at /home/mabro/roses/u-af404/meta.
Some functionality has been switched off.

rose.metadata_check.MetadataChecker: issues: 3
    'meto_cray'jinja2:suite.rc=MOOPROJECT=None=None
        No metadata entry found
    jinja2:suite.rc=SUBPROJECTS=pattern=^('aoil'|'esmdev'|'highres'|'seasonal'|'decadal'|'cmip6'|'ukcp18'|'ucc'|'mdvp'|'ocdc'|'cma'|'esms'|'ukesm'|'hadgem3ppe'|'other')*$
        Unnecessary property - 'values' overrides
    jinja2:suite.rc=SUBPROJECTS=value-titles=AOIL model development, ESM development, Exploratory high-resolution modelling,
 Seasonal Forecast production (inc. reanalysis), Decadal Forecast production, CMIP6, UKCP18,
 UCC Group, MDVP Group, OCDC Group, CMA Group, ESMS Group, UEKSM Group, Other
        Incompatible with values

One thing I also notice is that you have SUBPROJECTS declared twice in the rose-meta.conf file which will probably also cause problems.

Regards,
Ros

comment:2 Changed 3 years ago by mattjbr123

Great, thanks Ros, that seems to have worked.

One quick question - do you know if it's possible to change multiple STASH requests at once, e.g. sometimes I might want to change a bunch of requests to the same different time profile but I can only seem to do it one at a time at the moment.

Let me know if you want me to create another ticket for this.

Cheers,
Matt

comment:3 Changed 3 years ago by ros

  • Resolution set to answered
  • Status changed from new to closed
  • UM Version <select version> deleted

Hi Matt,

We did speak about this yesterday, and I have had another look since then and unfortunately the answer is No you can't change multiple STASH requests at once.

Regards,
Ros.

comment:4 Changed 3 years ago by mattjbr123

Nevermind, thanks for looking into it :)

Matt

Note: See TracTickets for help on using tickets.