Opened 3 years ago

Closed 3 years ago

#1992 closed help (fixed)

Adding new prognostic tracers and reconfiguring them

Reported by: luke Owned by: annette
Component: Rose Keywords: STASHmaster_A
Cc: Platform: ARCHER
UM Version: 10.4

Description

Hello,

I believe that I have an issue similar to #1795, although the solution there doesn't quite cover everything I need.

I would like to add 2 new UKCA tracers in Rose, and then add them to the reconfiguration so that they can be set to some value (or initialised from a file). I can set them to be initialised, but then the reconfiguration complains that these tracers don't exist in the STASHmaster_A file it is using.

I have done as #1795 suggested, and the suite runs. However, the tracers do not appear in the dump (as I might have expected as I initially didn't select them) or in the .pk file (which I would have expected, as I have asked them to be output here). There was no error from this run, which surprised me.

I have done as Section 7 suggests here: http://www.ukca.ac.uk/wiki/index.php/Using_the_UM10.5_test_suite , i.e.

  1. edit the app/um/rose-app.conf file to add in the STASHMSTR variable
  2. Set the file to be an fcm path to the PUMA mirror (i.e. source=fcm:um.xm_br/dev/user-id/your-branch-name/rose-meta/um-atmos/HEAD/etc/stash/STASHmaster@your-revision

However, it complains at 2, as I it has problems resolving the fcm path (I think). The information linked to from #1795 suggests making a app/file directory containing the STASHmaster_A file, but this doesn't work as Rose then complains that it can't find the app/file/rose-meta.conf file.

I am attempting to duplicate 2. above, but by manually rsync-ing the STASHmaster file and putting the directory that contains it as source=/work/n02/n02/luke/STASHmaster. This does work. However, it doesn't seem like it should be the best solution, as there can always be an easy-to-create disconnect between the STASHmaster_A used by the Rose metadata to create STASH requests and reconfiguration entries, and the STASHmaster_A used by the actual models as they run (i.e. when they are not synced across correctly, as this needs to be done manually).

Is there a good way to get this to work, i.e. one that only involves having the edited STASHmaster_A on PUMA (and preferably only in one location!)?

I have been working with u-ag308, although from a working copy which has had several changes covering the different scenarios above.

Many thanks,
Luke

Change History (8)

comment:1 Changed 3 years ago by luke

P.S. - by this does work I mean that the reconfiguration runs and seems to insert the two new tracers correctly. These are from the ag308.astart file:

 224  : 192   144   86    1     Field code =  2164
 225  : 192   144   86    1     Field code =  2165

However, I now get an error in atmos_main, which I need to track down next! I don't believe that this is connected with the problem described here - it's probably just a Red Herring. I'll try turning off pressure-level output of these tracers and see what happens.

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 51064
?  Error from routine: UKCA_MAIN
?  Error message: Item for P_LEVS not found in D1 array
?  Error from processor: 59
?  Error number: 15
????????????????????????????????????????????????????????????????????????????????

Thanks,
Luke

comment:2 Changed 3 years ago by luke

I can confirm that the above error was a mistake of my own making, since corrected by adding the tracers into UKCA.

However, the main problem remains. Is there a way to do run Rose without needing to use your own copy of STASHmaster_A manually copied to the supercomputer?

Thanks,
Luke

comment:3 Changed 3 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

Hi Luke,

If I understand correctly, the problem is that it tries to extract the STASHmaster_A file on ARCHER, which won't work as ARCHER can't see the repository. So what we want to do is extract on PUMA and copy over to ARCHER with the other app files?

I have an idea about how to possibly do this so I will play around and get back to you.

Annette

comment:4 Changed 3 years ago by luke

Hi Annette,

Yes, essentially. I don't really mind how it's done, but it would be nice if Rose didn't require the manual copying of STASHmaster_A files, if that makes sense!

Many thanks,
Luke

comment:5 Changed 3 years ago by annette

  • Component changed from UM Reconfiguration to Rose

Hi Luke,

It makes perfect sense. We have seen this problem before, but I have only just thought of how to get around it!

If you set the file source in the rose-suite.conf file, it will extract the file on PUMA when the suite is submitted, and this will be copied over with the other suite files to the HPC.

In your rose-suite.conf file add the following lines (substituting your branch):

[file:app/um/file/STASHmaster] 
source=fcm:um.xm_br/dev/user-id/your-branch-name/rose-meta/um-atmos/HEAD/etc/stash/STASHmaster@your-revision

Annette

comment:6 Changed 3 years ago by luke

Hi Annette,

Thanks - I'll try this. Can I check what I need to do to the app/um/rose-app.conf file? Currently I have the lines

STASHMSTR=STASHmaster

and

[file:STASHmaster]
source=/work/n02/n02/luke/STASHmaster

that I added myself.

Thanks,
Luke

comment:7 Changed 3 years ago by annette

Hi Luke,

I think you still need the:

STASHMSTR=STASHmaster

But get rid of the [file:STASHmaster] lines.

Annette

Last edited 3 years ago by annette (previous) (diff)

comment:8 Changed 3 years ago by ros

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.