Opened 3 years ago

Closed 3 years ago

#1996 closed help (fixed)

Job submission from PUMA failing/permission denied

Reported by: vegan Owned by: annette
Component: ARCHER Keywords: ARCHER umshared
Cc: Platform: ARCHER
UM Version: 4.5

Description

I'm having difficulties submitting a HadCM3-job (xmxb.a) via the UMUI from PUMA - I am getting a permission denied error (which would imply that the username (vegan) and the password would be wrong. However, I can log in fine to ARCHER directly.
See the attached screenshot for the output from both the UMUI and PUMA.

I am suspecting this relates to an error I am getting from the .profile on ARCHER (highlighted below):
login.archer.ac.uk


For assistance please contact the service helpdesk at: support@…


IF YOU ARE NOT AUTHORISED TO USE THIS ACCOUNT THEN YOU MUST LOGOUT IMMEDIATELY

USE OF THIS ACCOUNT BY ANYBODY OTHER THAN THE REGISTERED HOLDER IS NOT PERMITTED


================================================================================
-bash: HISTCONTROL: readonly variable
-bash: PROMPT_COMMAND: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: HISTSIZE: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: PROMPT_COMMAND: readonly variable
-bash: HISTCONTROL: readonly variable
-bash: HISTSIZE: readonly variable
-bash: /work/n02/n02/hum/bin/loadcomp: Permission denied

If I remove my .profile on ARCHER the login from PUMA works but my job misses the .profile on ARCHER and does not want to run the job, either. But it logs in fine. So it is not a wrong password or user name. The .profile was just copied from someone else (maxllo) and only the user name was modified.

Attachments (1)

perm_denied_error.png (240.3 KB) - added by vegan 3 years ago.
Screenshot UMUI/Archer login

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by vegan

Screenshot UMUI/Archer login

comment:1 Changed 3 years ago by annette

  • Component changed from UMUI to ARCHER
  • Keywords ARCHER umshared added; ARCHER, PUMA, UMUI, profile removed
  • UM Version changed from <select version> to 4.5

Hi Kira,

The issue is to with access permissions for the UM software directory. All users now need to be part of the "umshared" package account on ARCHER, which we have added you to.

Please try again to submit your job.

Annette

comment:2 Changed 3 years ago by annette

  • Owner changed from um_support to annette
  • Status changed from new to assigned

comment:3 Changed 3 years ago by vegan

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks, it now worked - I submitted successfully.

Note: See TracTickets for help on using tickets.