Opened 3 years ago

Closed 3 years ago

#2003 closed help (fixed)

UM version 8.5 (GA6.0, N96) with ECMWF start dump

Reported by: a.chevuturi Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.5

Description

Hello NCAS-CMS

I am trying to initialize UM version 8.5 (GA6.0, N96) with ECMWF start dump for a one year hindcast simulation for 1992. the job id is xmxey under my PUMA username a.chevuturi. My ARCHER username is 'achev'. On running the job simulation, I get the following error during reconfiguration from rcf.leave file:

/work/n02/n02/achev/xmxey/bin/qsrecon: Error in dump reconfiguration - see OUTPUT
*

Ending script : qsrecon
Completion code : 134
Completion time : Wed Oct 19 13:43:13 BST 2016

*

/work/n02/n02/achev/xmxey/bin/qsmaster: Failed in qsrecon in job xmxey

<<<< Information about How Many Lines of Output follow >>>>
276 lines in main OUTPUT file.
2562 lines of O/P from pe0.
<<<< Lines of Output Information ends >>>>

==============================================================================

=================================== OUTPUT ===================================
==============================================================================

UMUI Namelist output in /work/n02/n02/achev/xmxey/xmxey.umui.nl
DATAW/DATAM file listing in /work/n02/n02/achev/xmxey/xmxey.list
STASH output should be in /work/n02/n02/achev/xmxey/xmxey.stash

I am stumped as to what this error is. My home and work directories are open for you to view. I am attaching my comp.leave and rcf.leave files. Can you suggest and help me with the simulation. Please let me know if I need to provide anything else from my end.

Thanks
Amulya

Attachments (1)

xmxey000.xmxey.d16293.t121229.rcf.leave (163.1 KB) - added by a.chevuturi 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by a.chevuturi

comment:1 Changed 3 years ago by a.chevuturi

Sorry comp.leave did not get attached due to file exceeding upload limit. But it is there in my ARCHER output folder.

Thanks
Amulya

comment:2 follow-up: Changed 3 years ago by willie

Hi Amulya,

If you look in the pe_output for processor 24, you will see that the model can't find field 0,9 - soil moisture content in a layer. The simplest way to overcome this is to get the field from a standard ancillary file, in this case the file is in $UMDIR/ancil/atmos/n96/smow/gswp2_hwsd_vg/v1 and it's called qrclim.smow.

So in the UMUI, go to Ancillary and Input Data > Climatologies and … > Soil moisture and snow depth; enter the directory name and file name at the top and then select 'configured' for both 'snow depth' and 'MOSES hydrology'. The just run your model again.

It's possible other fields may be missing, so we may need to repeat the process. Let me know how it goes.

Regards
Willie

comment:3 in reply to: ↑ 2 Changed 3 years ago by a.chevuturi

Hi Willie,

Thank you so much for your quick response. You are right that the after correcting the soil moisture content in layer, the model can't find field 101 (I think it is SO2 MASS MIXING RATIO AFTER TSTEP). This error showed up in the most processors in pe_output that I checked randomly.

As you said some iterations might be needed to get it running correctly. Please let me know the path for the climatology of this variable or if another method is used to correct this error.

Thanks once again.

Regards
Amulya

comment:4 follow-up: Changed 3 years ago by willie

Hi Amulya,

Whew! I've now got it to reconfigure, as follows,

  • In section 17 Aerosols, switch off the sulphur cycle and the soot scheme. Press OCFF and switch off fossil fuels
  • switch off pre STASH ticket5571 as iceberg calving is not in 8.5
  • In ancillaries section, sulphur cycle emissions (3D), set Natural SO2 emissions to not used
  • Changed SMOW directories to $UM_ANCIL_SMOW_DIR and $UM_ANCIL_SMOW_FILE
  • Set snow depth configuration to "not used"

See my job xmyza. So some science was switched off and some ancillaries deselected. I am not sure if the model will run like this.

I hope this will be of use to you.

Regards
Willie

comment:5 in reply to: ↑ 4 Changed 3 years ago by a.chevuturi

Hi Willie

I did make the changes you suggested but the job still did not work. On the suggestion of someone at Met Office, I ran the job with aerosol modeling switched off, which cleared up the previous error. I ran this under new job id XMXE.C. But now with this new run I am getting the following error:

IO: from environment variable SMCSNOWD
replanca_rcf_replanca: UPDATE REQUIRED FOR FIELD 193 : Snow depth (M)

I1,STASHANCIL(irec) 0 376 169

Error in replanca_rcf_replanca
CMESSAGE replanca_rcf_replanca: PP HEADERS ON ANCILLARY FILE DO NOT MATCH
ErrorStatus? 393

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!???!!!?
? Error in routine: Rcf_Ancil_Atmos
? Error Code: 393
? Error Message: replanca_rcf_replanca: PP HEADERS ON ANCILLARY FILE DO NOT MATCH
? Error generated from processor: 0
? This run generated 1 warnings
????????????????????????????????????????????????????????????????????????????????

Can you suggest something about this error.

Thanks a lot.

Regards
Amulya

comment:6 follow-up: Changed 3 years ago by willie

Hi Amulya,

You need to set snow depth to "not used" in the ancillary panel. The ancillary file contains snow amount, which is different from snow depth, after UM 8.4. The help panel explains a bit more.

Willie

comment:7 in reply to: ↑ 6 Changed 3 years ago by a.chevuturi

Hi Willie

The model ran with this change without an error.

Thanks a lot for your help.

Cheers
Amulya

Last edited 3 years ago by a.chevuturi (previous) (diff)

comment:8 Changed 3 years ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.