Opened 12 years ago

Closed 12 years ago

#202 closed help (fixed)

SEGMENTATION FAULT

Reported by: salvatore Owned by: um_support
Component: UMUI Keywords: ocean mod
Cc: Platform:
UM Version:

Description (last modified by ros)

I have to include one modset to a FAMOUS run on HECTOR. When on hpcx things used t work fine, but now on HECTOR the run stops after 24 timesyeps when I include such modset and in the .leave file several segmentation faults are given.

The job is: xdoif

I attach the modset (ocean.f) and the stashmaster file for the diagnostic contained into the modset.

Attachments (4)

ocean (5.8 KB) - added by salvatore 12 years ago.
ocean.sm (11.5 KB) - added by salvatore 12 years ago.
ocean.2.sm (11.5 KB) - added by salvatore 12 years ago.
ocean.f (5.8 KB) - added by salvatore 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by salvatore

Changed 12 years ago by salvatore

comment:1 Changed 12 years ago by ros

  • Description modified (diff)

Modset and STASHmaster file contents removed from description as Salvatore has now supplied them correctly as attachments. Thanks.

comment:2 Changed 12 years ago by jeff

Hi

I had a look at the .leave files for job xdoif, it seems the later versions of this job work. So can you tell me which file has the problem and what changes did you make to the later versions?

Jeff.

comment:3 Changed 12 years ago by salvatore

It seemed that the problem was the modset ocean: in fact if you have a look to the earlier .leave files you see the segmentation faults. But now including the same one it seems it's running properly

I don't know why it didn't work earlier.

comment:4 Changed 12 years ago by salvatore

Hello,
I have always the same problem, which seemed to be solved but it is not: the job is xdoif (FAMOUS). When I include the modset ocean.f I got segmentation fault. I attach again the file ocean.f and the STASHmaster ocean.sm.

Many thanks in advance.

Salvatore Pascale
University of Reading, Department of Meteorology

Changed 12 years ago by salvatore

Changed 12 years ago by salvatore

comment:5 follow-up: Changed 12 years ago by jeff

Hi Salvatore

Your run seems to be crashing in routine row_ctl in line

      TSUR(i,j)=d1(joc_tracer(1,1)+ipoint2)+ZERODEGC

So it looks like your mod is the problem, where did you get it from? When I put in print statements to try and find out what the problem is the code doesn't crash any more. This makes debugging the problem hard. If I lower the optimisation option on routine row_ctl then it works for me, so you could try this. Create a compile override file containing this line

ROW_CTL FCOM_OPTIM=-O2

and go to this umui window

Sub-Model Independent → Compilations and Modifications → User-defined compile option overrides

Enter your file name in the top panel. Let me know if this solves the problem.

Jeff.

comment:6 in reply to: ↑ 5 Changed 12 years ago by salvatore

Hi Jeff,
after your modification it seems to work well. Why this problem didn't come out on hpcx?

Salvatore

Replying to jeff:

Hi Salvatore

Your run seems to be crashing in routine row_ctl in line

      TSUR(i,j)=d1(joc_tracer(1,1)+ipoint2)+ZERODEGC

So it looks like your mod is the problem, where did you get it from? When I put in print statements to try and find out what the problem is the code doesn't crash any more. This makes debugging the problem hard. If I lower the optimisation option on routine row_ctl then it works for me, so you could try this. Create a compile override file containing this line

ROW_CTL FCOM_OPTIM=-O2

and go to this umui window

Sub-Model Independent → Compilations and Modifications → User-defined compile option overrides

Enter your file name in the top panel. Let me know if this solves the problem.

Jeff.

comment:7 Changed 12 years ago by jeff

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.