#2045 closed help (fixed)

Build HPC fail

Reported by: amenon Owned by: annette
Priority: normal Component: Rose
Keywords: submit-fail ssh Cc:
Platform: ARCHER UM Version: 10.5

Description

I am doing my nested suite production run at the moment. I have an issue with it, 'build HPC (fcm make2)' job is failing to submit. As it is a submit-fail error I can't see any .err or .log files. So have no idea why it is failing. Could you please help? I tried re-triggering it several times, but doesn't help! My suite id is u-ai540. Here is the rose bush link
http://puma.nerc.ac.uk/rose-bush/taskjobs/amenon/u-ai540

Thanks,
Arathy

Change History (4)

comment:1 Changed 22 months ago by annette

  • Keywords ssh added
  • Status changed from new to assigned
  • UM Version changed from <select version> to 10.5

Hi Arathy

In rose-bush, if you click on "cylc files" at the top then "log/suite/err" you will see this is where the submission errors have gone. There is a "permission denied" error connecting to Archer which suggests that your ssh-agent isn't working properly.

Are you able to ssh into ARCHER on the command-line without being asked for a passphrase? If you are asked for a passphrase, you will need to restart your agent. See here for details:

http://cms.ncas.ac.uk/wiki/FAQ_T4_F14
http://cms.ncas.ac.uk/wiki/FAQ_T4_F5

Annette

comment:2 Changed 22 months ago by amenon

Hi Annette,

Thanks a lot. I solved the issue just 5 minutes ago. As you suggested, I was not able to log into Archer without passphrase, ssh-add was not working too; so deleted environment.puma (as suggested in one of the old tickets in ncas-cms) and did ssh-add again. Then it worked. After that I was trying to restart the suite which didn't solve the problem. But when I started the suite from scratch with 'rose suite-run', it worked.

Cheers,
Arathy

comment:3 Changed 22 months ago by amenon

Its great to know that the submission errors can be viewed in rose-bush. It will be very useful in the future. Thanks so much Annette.

Cheers,
Arathy

comment:4 Changed 22 months ago by annette

  • Resolution set to fixed
  • Status changed from assigned to closed

Great glad you got it working!

Annette

Note: See TracTickets for help on using tickets.