Opened 3 years ago

Closed 3 years ago

#2085 closed help (answered)

rebuild_nemo utility not working on MONSooN

Reported by: mk1812 Owned by: um_support
Component: NEMO/CICE Keywords: rebuild_nemo, MONSooN
Cc: Platform: MONSooN
UM Version: 8.2

Description

Hi,

Sorry to trouble you. I've recently found that the rebuild_nemo utility used to recombine NEMO output files doesn't seem to be working anymore. When I try and run it manually with some example output files, I get the following error:

file xkcxko_20880211_restart, num_domains 32, num_threads 1

Running OMP with 1 thread(s).

/projects/ocean/nemo/utils/bin/rebuild_nemo: line 105: 36117: Illegal instruction
Illegal instruction

I have tried running it on both the xcm and postproc, and both give the same result. I know the utility was working fine as of early December, so this is a fairly recent development; I'm not sure what has changed since then that would cause it to fail.

Many thanks in advance for any insight you could give!

Matt

Change History (3)

comment:1 Changed 3 years ago by annette

Hi Matt,

The executables in /projects/ocean/nemo/utils/bin are not compiled for use on the login nodes. However you can submit to the batch nodes with the -l option. For example the following worked for me with some files restart*.nc:

/projects/ocean/nemo/utils/bin/rebuild_nemo -l restart 192 

Annette

comment:2 Changed 3 years ago by mk1812

Hi Annette,

Ok, that seems to be working, thanks. I usually call rebuild_nemo as part of the user script release in a UM job, but it was failing to rebuild any of my NEMO output since the start of the year, which is why I was trying to manually test the utilty on the login node (which used to be possible on the old IBM). I've realised that my UM user script was actually pointing to an older version of the rebuild_nemo utility (located in ~jwalto/ported/scripts/hadgem3/rebuild_nemo/rebuild_nemo), and so the problem must have been with that version of the utility. Changing my scripts to point to the version in /projects/ocean/nemo/utils… seems to have fixed the problem, provided it is submitted as a job to the compute nodes as you suggest.

Many thanks again for clearing that up!

Best,
Matt

comment:3 Changed 3 years ago by annette

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.