Opened 12 years ago

Closed 12 years ago

#209 closed help (fixed)

difficulty running global model from ECMWF start dump

Reported by: anmcr Owned by: willie
Component: UM Model Keywords: global model, ecmwf start dump
Cc: Platform:
UM Version:

Description

Hello,

I've having difficulty running the global UM from ECMWF ERA40 start data.

I have achieved the following
i) Reconfigured the ECMWF start dump to a N216 UM start dump. I used the template basis file supplied on the PUMA umui. This is at ~anmcr/work/xdopb/DATAW.
ii) Run the N320 global model using the sample UM start dump on Hector and the template basis file from the PUMA umui. This is at ~anmcr/work/xdpoa

However, if I try to run the global model using the reconfigured ECMWF start dump then my run fails. I have tried a number of combinations which all fail
i) Modifying my above N320 run to N216, and then running using the ECMWF data. This is ~anmcr/work/xdmvh
ii) Using my zdpoa N320 run and reconfiguring the already reconfigured ECMWF start dump from N216 to N320. This is ~anmcr/work/xdpoc

Rather than going through all this, I thought it might be easier if you had a sample basis file for a
i) a N216 run which runs a reconfigured N216 ECMWF start dump
ii) a global N216 job for hector
iii) a N320 run which runs a reconfigured N320 ECMWF start dump

Thanks for any help. I have tried to sort this out myself but was not able to.

Andrew (anmcr)

Change History (5)

comment:1 Changed 12 years ago by willie

Andrew,
I have examined some of these jobs and found a few problems that have affected others too:

=xdpob=

  • This has the Section 96 problem: Go to submodel independent > submodel independent option > Misc section 94 and check box 1A of choose version for section 96
  • there are a couple of small check setup error that can be solved by visiting the page and closing.

=xdmvh=

  • there are a number of check setup errors that need to be solved
    • Atmos > Science > Level by level replace 50 by 38
    • Atmos > Science > Secetion by section > Sect 13 follow on TARG - replace 50 by 38
  • The packing profile must be 0. Submodel indep > Post Proc > initialisation. Change each packing profile to 0.

=xdpoc=

  • ensure packing profile as per xdmvh

The packing issue and the section 96 issue can cause errors (Nans and segmentation faults). Visit submodel indep Emsemble and File resubmision and close these to correct the remaining minor problems. Check setup should then report no problems.

Let me know how you get on with this.

Regards
Willie

comment:2 Changed 12 years ago by anmcr

Hello Willie,

Thank you very much for looking at these.

I've now succeeded in running the N216 global model using the ECMWF start dump. This was experiment xdmvh.

The other attempt which was to first reconfigure the N216 reconfigured ECMWF start dump to N320 and then run, failed with a segmentation error in the reconfiguration. This was run xdpoc. Check_setup showed no errors. However, I'm happy to leave this as it stands as this was only really a desperate attempt to get the model run to work.

Thanks again,

Andrew

comment:3 Changed 12 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to assigned

Andrew,

I now have two standard UMUI jobs for reconfiguring ECMWF GRIB data: an N216 and an N320, as you suggested. These are xdkea and xdkeb, under user umui.

Regards,
Willie

comment:4 Changed 12 years ago by anmcr

Hello Willie,

Thanks for the basis files.

Andrew

comment:5 Changed 12 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.