#2100 closed help (worksforme)

Activation of Nudging causes non-descriptive segmentation fault.

Reported by: mhollaway Owned by: um_support
Priority: normal Component: UM Model
Keywords: Nudging, UKCA Cc:
Platform: MONSooN UM Version: 10.5

Description

Hi,

I am having some issues with the activation of the nudging routines. The suite (u-ak524) runs absolutely fine with nudging switched off. As soon as I activate the nudging in rose (following the instructions in UMDP 083) the model falls over on the first timestep with the following errors in the job.err file.

[194] exceptions: An exception was raised:11 (Segmentation fault)
[196] exceptions: An exception was raised:11 (Segmentation fault)
[194] exceptions: the exception reports the extra information: Address not mapped to object.
[196] exceptions: the exception reports the extra information: Address not mapped to object.

The job.err file also points to which line of code causes the fault however as no core is dumped I am not able to run a debugger on the core file to check this is actually the line causing the crash. Therefore I am unable to track the source of the error.

[143] exceptions: [backtrace]: ( 7) : nudging_nudging_control_ in file /home/mhollo/cylc-run/u-ak524/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/nudging/nudging_nudging_control.F90 line 274

As mentioned above the suite runs fine with the nudging code off. Would you be able to advise on how to best solve this error and activate the nudging code?

Best Wishes,

Michael.

PS. I attach the job.out and job.err files in case they help with details of the cause of the problem.

Attachments (2)

job.out (164.5 KB) - added by mhollaway 20 months ago.
Job Output file
job.err (574.0 KB) - added by mhollaway 20 months ago.
Job error file

Download all attachments as: .zip

Change History (7)

Changed 20 months ago by mhollaway

Job Output file

Changed 20 months ago by mhollaway

Job error file

comment:1 Changed 20 months ago by luke

Hi Michael,

It could be that not all the required diagnostics have been selected as TALLTS in STASH. I have recently got a vn10.6.1 GA7.1 development suite working nudged (my u-ak353) and I needed to include m01s30i451 (tropopause pressure) to get it to work.

Given that your u-ak524 is already on MONSooN, if you can't get it working and you don't need to keep using vn10.5, you could take a copy of my suite instead. Note that this is still technically in development. You could also compare settings between these suites, although as mine is vn10.6.1 GA7.1 there will be many differences not associated with nudging.

Thanks,
Luke

Last edited 20 months ago by luke (previous) (diff)

comment:2 Changed 20 months ago by mhollaway

Hi Luke,

Thanks for getting back to me. I did think initially that I was missing the tropopause pressure from STASH but thought I had updated since then. I will double check to make sure I have not missed that.

With respects to versions. I am not particularly tied to vn10.5 at present as this was the version I was given a test suite for. The ultimate aim is to test my FASTjx GLOMAP coupling code with nudging when I evaluate against observations. Therefore it makes sense if I run with a more recent version so might try running with a copy of your suite instead.

From looking at previous tickets I think I may also have to update to version 10.6 to pick up the corrections that solve the issue with the gregorian calendar (needed for nudging) and the netCDF emissions?

Cheers

Michael.

comment:3 Changed 20 months ago by luke

Hi Michael,

If you haven't run fcm commit in your suite then you may have updated the STASH but I couldn't tell I'm afraid.

According to Mohit, nudging is fine from the trunk at vn10.6. The only changes I needed to make to the suite were the nudging settings and the extra STASH.

This suite is probably the better one to take, especially as it's GA7.1 so has improved tunings for GLOMAP. Let me know how you get on.

Thanks,
Luke

comment:4 Changed 20 months ago by mhollaway

Hi Luke,

Thanks for all the help on this. I have taken a copy of your suite (u-ak353) and it runs fine (both with and without my updates included). I am just running a longer run overnight with my updates included for the FASTJX-GLOMAP coupling to double check everything but otherwise everything now seems ok.

Thanks again,

Cheers

Michael.

Last edited 20 months ago by mhollaway (previous) (diff)

comment:5 Changed 20 months ago by luke

  • Resolution set to worksforme
  • Status changed from new to closed

Hi Michael,

It's great that the job works. I'll close this ticket now.

Best wishes,
Luke

Note: See TracTickets for help on using tickets.