Opened 2 years ago

Closed 2 years ago

#2107 closed error (fixed)

cannot logon to monsoon lander

Reported by: s1374103 Owned by: ros
Component: UM Model Keywords: logon, lander, monsoon
Cc: Platform: Monsoon2
UM Version:



Since yesterday I haven't been able to logon to the monsoon lander.

From my computer I do…

ssh -Y

It prompts me for my passcode, but when I enter it, the rejects it and prompts me for the passcode again. I tried it a couple of times yesterday, then again this morning and it's doing the same thing.

I have a Met Office Desktop account/user-id and I know that since yesterday my username changed to mon_user_jakel, but I thought this was only for accessing mass and not accessing lander.



Change History (21)

comment:1 Changed 2 years ago by s1374103

  • Keywords logon, lander, monsoon added
  • Platform set to MONSooN
  • priority changed from normal to high
  • Type changed from help to error

comment:2 Changed 2 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Jamie,

Your username on lander should be the same as your username on the XCS-C now.


Version 0, edited 2 years ago by ros (next)

comment:3 Changed 2 years ago by ros

Hi Jamie,

Sorry, hit submit prematurely - Please try logging into Lander with your Met Office CDN username.


comment:4 Changed 2 years ago by s1374103

Hi Ros,

I just tried my new username (kjamie) and that takes me to the lander ok. From there I can then access xcs-c. However, I how do I get from the lander (logged in as kjamie) to the xcm (where my data is under the username jakel)?

I have a few jobs running/finishing as my old username on xcm and I was hoping to find them and copy over / delete.



comment:5 Changed 2 years ago by ros

  • Status changed from accepted to pending
  • UM Version <select version> deleted

Hi Jamie,

This is a known issue for those who have changed userids (I have the same problem) and the Met Office are working to solve this as soon as possible. See the Twiki for updates:


comment:6 Changed 2 years ago by ros

An update:

You should now be able to login from xcs-c to xcm:

ssh <old_userid>@xcm

But it is still not possible to login to xcm direct from lander.

comment:7 Changed 2 years ago by s1374103

Hi Ros,

Thanks for that. I can now access both xcs-c and xcm.

After recreating the .moosedir/moose file on xcs-c I tried to access the moose directory where some of my model output is (moose:/adhoc/users/mon_ukca/jakel) but I get the following error

ls: (failed with code ERROR_AUTHORISATION) permission denied.
//////////////////////////////////////////////////////////////////////// org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://exxmobsslprd:8439/controller/moose.service]; nested exception is Did not receive successful HTTP response: status code = 401, status message = [Unauthorized]

So then, I did 'ssh <old_userid>@xcm' and tried to access again bu t I had the same error message.

Am I correct in thinking that the directory I'm looking for is going to be unaffected by the switch from xmc to xcs-c?



comment:8 Changed 2 years ago by ros

Hi Jamie,

Just to check; when you say "recreating .moosedir/moose file on xcs-c" you mean using the new credentials files that you were emailed on Tuesday and not copying the ones from the xcm?


comment:9 Changed 2 years ago by s1374103

Hi Ros,

Yes, I used the new credential files. I only put a copy of this on /home/d04/kjamie, not on /home/jakel.



comment:10 Changed 2 years ago by ros

Hi Jamie,

I've just tried mine out too but get a different permission denied message. Can you let me know the exact command you are running and I will get advice from the Met Office.


comment:11 Changed 2 years ago by luke

Hi Jamie, Ros,

I just tried my new moose credentials on the xcs-c and these worked without problems for me. Can I check that you have

chmod 600 moose

prior to trying to use the moo command? This file should be placed in $HOME/.moosedir.


comment:12 Changed 2 years ago by ros

Hi Luke,

Hmmmm. I definitely do have the permissions correct as I initially didn't and it told me. I've just checked Jamie's and his are 600 too.

Thanks for the idea though.


comment:13 Changed 2 years ago by luke

Hi Ros,

Just a thought!

I also had two sets of credentials file sent to me. I used the second set.


comment:14 Changed 2 years ago by s1374103

Hi All,

Here's what I did.

I created a a directory (.moosedir) at my home (/home/d04/kjamie).

I then copied the new credentials moose file (moose)

Changed the permission to 600.

If I type 'moo' I get the following;

Usage: moo <sub-command> [options] [arguments]

Met Office Operational Storage Environment (MOOSE) command-line client.
Type "moo help <SUB-COMMAND>" for help on a specific sub-command.

Available sub-commands (note that some sub-commands are not available
to some types of user and on some client-platforms):
        for creating, modifying, or retrieving comments applied to data sets and collections
  dls, displs, disposels
        List data which has been marked for deletion using the dispose command
        atomic retrieval (.nc files only)
        retrieves files from the archive
  help, h, ?, --help, --usage
        prints help for this command or its applications
        sends a kill signal to running commands
  ls, list
        prints a listing of directories/files in the archive
  mdls, mls
        atomic listing
        makes directories in the file system archive
        makes data sets in the archive
  passwd, password, pw
        allows user to change MOOSE password (ONLY USE DIRECTLY WITH -r OPTION!)
  projinfo, projectinfo, prinf
        displays information about the specified projects
  projlist, projectlist, prls, projectls
        lists projects with which the user is associated
        copies files to the archive
  quality, qual
        for creating, removing, modifying or retrieving quality records applied to data sets, collections, directories and files
        for resuming execution of a previously issued retrieval command
        atomic retrieval (.tar/.pp collections and .nc files only)
  setinfo, seti
        displays information about a specified set
  suspend, susp
        move commands to a suspended state
  sysinfo, si, info
        displays information about the current MOOSE system
        test status of MOOSE URI

MOOSE is maintained by the MOOSE team at Met Office, UK.
(C) Crown copyright Met Office. All rights reserved.

So, presumably, my credentials/permission are setup correctly as the 'moo' command is being recognised (like Ros, when I hadn't set the permission correctly moo was not being recognised and I was promoted to change permission).

I have manually stored model output in 'moose:/adhoc/users/mon_ukca/jakel/'.

If I enter the following;

moo ls moose:/adhoc/users/mon_ukca/jakel/

I get this error message;

ls: (failed with code ERROR_AUTHORISATION) permission denied.
//////////////////////////////////////////////////////////////////////// org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://exxmobsslprd:8439/controller/moose.service]; nested exception is Did not receive successful HTTP response: status code = 401, status message = [Unauthorized]
ls: failed (2)



comment:15 Changed 2 years ago by ros

Ok I must just have been trying a dodgey set. I've found another job I've archived and I can ls that one ok.

rhatcher@xcs-c$ moo ls moose:crum/xlpod

I'm going to send your problem off to the Met Office and see what they say.


comment:16 Changed 2 years ago by ros

Hi Jamie,

Could you try again from xcs-c now please?


P.S. I've been told you won't be able to access MASS from the XCM now.

comment:17 Changed 2 years ago by s1374103

Hi Ros,

Just tried it again and it's working now… Thankyou so much for your help!

Can I just clarify something…

I now have a new userid which I use to access xcs-c. From there I access my old data which is attached to me old userid. Will I continue to use this space with my old userid or will I be assigned a new area (with my new userid).



comment:18 Changed 2 years ago by ros

Hi Jamie,

Glad to hear that is working for you now. Somehow your MASS account had got disabled.

Regarding userids… Your MASS userid will NOT change it will remain as mon_user_jakel.


comment:19 Changed 2 years ago by s1374103

Hi Ros,

I am trying to transfer some data from xcm to xcs-c.

On xcm I go to /projects/ukca-ed/<old-userid>

And I try to copy over using the follwoing;

scp -r xnfag xcslc0:/projects/ukca-ed/<new-userid>
rsync -av . xcslc0:/projects/ukca-ed/<new-userid>

However, both these attempst return the follwoing…


I tried entering in my passcode but that didn't work.

Some of the people in my office have used this command to transfer their data over and it worked fine. However, they have no chnage in user id so I'm wandering if this is the problem.

Do you know if anyone else is having this problem?



comment:20 Changed 2 years ago by ros

Hi Jamie,

Have you set up your ~/.ssh/config on XCM so that ssh knows what userid to use when logging into XCS-C? If not then you will need to copy over using:

 rsync -av . <new-userid>@xcslc0:/projects/ukca-ed/<new-userid>

Also have you setup your ssh-keys to get from XCM to XCS? See You will need to know your XCS password (not your fob passcode) to do this which the Met Office will have sent you a while ago.

Alternatively, and probably easiest from the XCS pull the files from the XCM.

xcs-c$ rsync -av <old-userid@xcm:/projects/ukca-ed/<old-userid> .


comment:21 Changed 2 years ago by ros

  • Platform changed from MONSooN to Monsoon2
  • Resolution set to fixed
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.