#2127 closed help (fixed)

rose um on XCS-C

Reported by: ggxmy Owned by: um_support
Priority: normal Component: UM Model
Keywords: Cc:
Platform: Monsoon2 UM Version: 10.6

Description

Dear CMS,

Following suggestion by Ros in #2162, I changed

            host = $(rose host-select xcm)

into

            host = $(rose host-select xcsc)

in /home/d03/myosh/roses/u-al036/site/MONSooN.rc . This was only place where I found 'xcm' so I changed it. When I tried to run the suite I got an error like this;

/home/d03/myosh/.bash_profile: line 14: /home/d03/myosh/.ssh/ssh-setup: No such file or directory
[FAIL] use = /projects/ukca-admin/code/vn10.6.1_prebuild/share/fcm_make_um: incorrect value in declaration
[FAIL] config-file=/projects/ukca-leeds/myosh/cylc-run/u-al036/work/19880901T0000Z/fcm_make_um/fcm-make.cfg:1
[FAIL] /projects/ukca-admin/code/vn10.6.1_prebuild/share/fcm_make_um/.fcm-make/ctx.gz: cannot retrieve cache
[FAIL] No such file or directory at /common/fcm/fcm-2017.02.0/bin/../lib/FCM/System/Make/Share/Dest.pm line 106, <$handle> line 1.

[FAIL] fcm make -f /projects/ukca-leeds/myosh/cylc-run/u-al036/work/19880901T0000Z/fcm_make_um/fcm-make.cfg -C /home/d03/myosh/cylc-run/u-al036/share/fcm_make_um -j 6 # return-code=2
Received signal ERR
cylc (scheduler - 2017-03-23T14:49:03Z): CRITICAL Task job script received signal ERR at 2017-03-23T14:49:03Z
cylc (scheduler - 2017-03-23T14:49:03Z): CRITICAL failed at 2017-03-23T14:49:03Z

Maybe I can ignore the first line because I get this all the time…? At the second line, there seems no such thing as /projects/ukca-admin/code/vn10.6.1_prebuild/share/fcm_make_um . Maybe this is the problem? /projects/ukca-admin/code/vn10.6.1_prebuild/share/fcm_make_um/.fcm-make/ctx.gz in the forth line does not appear to exist either.

Could you help me?
Thanks,
Masaru

Change History (2)

comment:1 Changed 17 months ago by luke

Hi Masaru,

Mohit set-up pre-compiled builds on the XCM, but this hasn't been done on the XCS (yet, if at all). You can remove this line in one of two ways:

  1. In fcm_make_um → env → Basic compilation remove $PREBUILD from the prebuild dialogue box

OR

  1. In the suite-id/site/MONSooN.rc file edit the line
                PREBUILD = /projects/ukca-admin/code/vn10.6.1_prebuild/share/fcm_make_um
    
    to just be
                PREBUILD = 
    

If you do the latter I would suggest doing it without having the suite open. Once you have made your changes, run the suite. Remember to fcm commit it, otherwise if someone copies it they won't have this change included.

Thanks,
Luke

comment:2 Changed 17 months ago by ggxmy

  • Resolution set to fixed
  • Status changed from new to closed

Hi Luke,

I did #1 and this problem seems to have gone. Thank you very much for your help.

Masaru

Note: See TracTickets for help on using tickets.