Opened 3 months ago

Closed 7 weeks ago

#2136 closed help (fixed)

Model misinterpretting orientation of ancillary file - emissions are mirror image about the x-axis.

Reported by: s1374103 Owned by: um_support
Priority: high Component: UM Model
Keywords: emissions ancillary orientation Cc:
Platform: Monsoon2 UM Version: 8.4

Description

Hi Helpdesk

The model is viewing the orientation of my single level user ancillary files different to how I am seeing them when viewed in Xconv or plotted in python. The model is misinterpreting them by viewing them as a mirror image across the x-axis. This is not a problem with STASH as the spatial pattern of the tracer which they are emitted into is also incorrect.

Originating from the UKCA release job vn8.4 (RJ4.0 CheST+GLOMAP-mode, xlsjc) I have made several changes (described below). I intend to re-run my job at each stage of code change, however, I just thought I'd check with the helpdesk to see if this kind of problem has ever been observed before.

I'd also like to point out that several months ago I created a ticket in relation to the emissions code for vn8.4. What I done was add to new tracers. I then emitted the first tracer. The model ran. Emission of the second tracer resulted in a segmentation fault with an error message about the allocation/dellacoation of arrays related to ASAD. My code changes were reviewed and deemed acceptable and the cause for this segmentation fault was never discovered.

cms.ncas.ac.uk/ticket/1905

cms.ncas.ac.uk/ticket/1821

The code changes to this job are;

  1. Additional VOC tracer ('L_ANT_BB')
  1. Emission of L_ANT_BB from sinlge level user ancillary file.
  1. Edit to isoprene reactions (with OH, NO3 and O3) so that Sec_Org is also a product.
  1. additional reaction of L_ANT_BB and OH to form Sec_Org.
  1. Diagnostics for the above changes.

If you have any ideas as to how I could have cuased this problem I would really appreciate it.

Regards,

Jamie

Change History (5)

comment:1 Changed 3 months ago by luke

Hi Jamie,

Can I check how you are making your emissions ancillary up? If you are using Xancil you need to make sure that you set the UM version number to be correct for the version you are running (in this case vn8.4). The default in Xancil is vn4.5, and the nature of the grid used there was that it was the reverse in the way that you describe, so my initial thoughts are that this could be the issue. I'm not sure if this could then be causing your other problems as well, but it might be as the format of the file will be not what the model expects, so it might be making it behave in strange ways.

Can you look at any .job files you have from when you made up your emissions, or if these aren't available, could you make them up again, making sure that you specify vn8.4?

Many thanks,
Luke

comment:2 Changed 3 months ago by s1374103

Hi Luke,

Thanks for that. I can't remember how I made them up so I'll try re-creating them again.

Do you happen to know the path for Xancil on xcs-c? I'm struggling to find it.

Regards,

Jamie

comment:3 Changed 3 months ago by s1374103

Hi Luke,

After recreating the ancillary and remembering to specify vn8.4 the problem was solved! Thankyou so much. You've saved me a lot of time.

One other question. When I was searching for Xancil I found different versions. What are the differences between different versions and which one am I supposed to use?

Regards,

Jamie

comment:4 Changed 3 months ago by jeff

Hi Jamie

There is a list of the different versions of xancil here

http://cms.ncas.ac.uk/documents/xancil/

I would suggest using the latest version so you have all the bugfixes.

Jeff.

comment:5 Changed 7 weeks ago by ros

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.