Opened 2 years ago

Closed 2 years ago

#2158 closed help (fixed)

cylc-7.3.0 problem

Reported by: ggxmy Owned by: um_support
Component: Rose Keywords: cylc-7.3.0
Cc: Platform: Monsoon2
UM Version: 10.6

Description

Dear CMS,

My vn10.6.1 suite, u-al426, which previously ran, does not run now. Reconfiguration crashes with an error message;

[FAIL] file:STASHmaster=source=fcm:um.xm_tr/rose-meta/um-atmos/HEAD/etc/stash/STASHmaster@31236: bad or missing value

I searched tickets and found that this is exactly the same problem as #2156. However the remedy shown there doesn't seem to work for me. I did step 0 and got this;

myosh@exvmsrose:u-al426 $ CYLC_VERSION=7.3.0 cylc validate ~/cylc-run/u-al426/suite.rc.processed
Valid for cylc-7.3.0

This looks good. Then I tried step 1 but it didn't work;

myosh@exvmsrose:u-al426 $ CYLC_VERSION=6.11.4 cylc stop --now u-al426
"Port file '/home/d03/myosh/.cylc/ports/u-al426' not found - suite not running?."

Yes it IS running. Probably this is the problem. So I stopped the suite from rose edit.

In step 3, my rose-suite-run.conf already had CYLC_VERSION=7.3.0 so I changed only one line to
ROSE_VERSION=2017.02.0. Then instead of doing step 4, I pressed the run button in rose edit.

By this my problem has not been resolved and I still have the same problem. Could you please help me?

Masaru

Change History (6)

comment:1 Changed 2 years ago by ros

  • Status changed from new to pending

Hi Masaru,

The Monsoon team are investigating the problems with getting the STASHmaster file. This is totally separate to the cylc-6.x to cylc-7.x upgrade instructions. When we hear any further news I will update you. Also keep an eye out on the Yammer newsgroups/Monsoon Twiki as important system update/news are also posted there.

Cheers,
Ros.

comment:2 Changed 2 years ago by ggxmy

Thank you Ros. Above I said I stopped the suite from rose edit but it was actually from the window that opens when I run the suite (rose sgc?).

Masaru

comment:3 Changed 2 years ago by ros

Hi Masaru,

The Met Office have now resolved the issue with the MOM nodes. Please try running your suite again.

Cheers,
Ros.

comment:4 Changed 2 years ago by ggxmy

Hi Ros.,

The suite was reconfigured OK now, so the problem is likely to have been fixed. Thank you for sorting it out.

As I wrote above I changed a line in rose-suite-run.conf into ROSE_VERSION=2017.02.0. Do I need to make the same change for all jobs from now on?

Masaru

comment:5 Changed 2 years ago by ros

Hi Masaru,

You only need to make the change to suites that are already running under cylc-6.11.4. Just check any already running suites in the rose-suite-run.conf file to see what versions of Rose/Cylc are being used. Any suites you started running since the cylc upgrade will automatically run using cylc-7.3.0.

Cheers,
Ros.

comment:6 Changed 2 years ago by ggxmy

  • Resolution set to fixed
  • Status changed from pending to closed

Hi Ros.,

Thank you. I had actually noticed that rose-suite-run.conf or the entire cylc-run/SUITE directories containing this file exist only for suites that had been run previously. So I had to change this for two more jobs only.

Thank you for your help.
Masaru

Note: See TracTickets for help on using tickets.