Opened 3 years ago

Closed 3 years ago

#2171 closed help (fixed)

claim exceeding reservation's node-count

Reported by: ambrogio Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 10.5

Description

Dear Annette,

I am having problems in increasing the number of processors to use on Archer for my runs (suite u-al707).
This is the error I get when running the model after changing the number of processors from the cylc GUI (in Processor decomposition):
apsched: claim exceeds reservation's node-count
[FAIL] um-atmos # return-code=1

I checked the suite.rc and I can see that the relevant variables are defined in this way:

UM_ATM_NPROCX = {{ATM_PROC_X}}
UM_ATM_NPROCY = {{ATM_PROC_Y}}
[…]

TOTAL_MPI_TASKS = $((UM_ATM_NPROCX * UM_ATM_NPROCY))

So, to me it doesn't look like the problem is here.
I am using an n02-weat account and a standard queue. Is the problem related to this?

Many thanks for your attention and support

Best wishes,
Ambrogio

Change History (2)

comment:1 Changed 3 years ago by ambrogio

*UPDATE*

Dear Annette,

I have actually solved the problem changing -l select (from 1 to 16 in my case, as I want to use 16 nodes) in suite.rc.

Apologies for having asked you to spend time on it

Best wishes,
Ambrogio

comment:2 Changed 3 years ago by annette

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.