Opened 3 years ago

Closed 3 years ago

#2208 closed help (fixed)

STASHmaster: Read operation tried to read past the end-of-file

Reported by: marcus Owned by: um_support
Component: UM Reconfiguration Keywords: STASHmaster
Cc: Platform: NEXCS
UM Version: 10.6

Description

Hi,

I am facing the problem that during reconfiguration with modified STASHmaster file the following error occurs:

lib-4001 : UNRECOVERABLE library error
  A READ operation tried to read past the end-of-file.

Encountered during a sequential formatted READ from unit 10
Fortran unit 10 is connected to a sequential formatted text file:
  "STASHmaster/STASHmaster_A"
 Current format: (A1)

I am implementing a new tracer (s34i173) in suite u-an366 on MONSooN. I thereby am following the procedure as outlined in the UKCA vn10.4 tutorial 4.

The tracer has been initialised with a small value in section "Configure ancils and initialise dump fields" as described in the tutorial.

In difference to the tutorial I have moved my modified STASHmaster file to ~/roses/u-an366/app/um/file/STASHmaster and the corresponding code section in rose-suite.conf is:

[file:app/um/file/STASHmaster]
source='.'

I am not sure if it's relevant for this problem but the um meta-data points to the location ~/meta/vn10.6.1_ukca_diagn_alkyl/nitrates/rose-meta because this suite is copied from another suite (u-al408) which required meta data alterations.

The STASHmaster_A files in the meta data location and in the app/um/file/STASHmaster directories are identical, both contain the new tracer (I didn't know which one the model will eventually use).

Please what causes this problem. I noticed that this error has previously been discussed in ticket #1330 however this referred to a much older model version and I have initialised the new tracer, so I do not understand how this solution would apply here?

Many thanks,
Marcus

Change History (3)

comment:1 Changed 3 years ago by luke

Hi Marcus,

The issue I think is that the UM is trying to find

app/um/file/STASHmaster/STASHmaster_A

as you have put the following in your rose-suite.conf:

[file:app/um/file/STASHmaster]
source='.'

However, looking in your suite, the app/um/file directory is

[14:18:42 hadlk@exvmsrose file]$ pwd
/home/d03/makoe/roses/u-an366/app/um/file
[14:22:07 hadlk@exvmsrose file]$ ls
STASHmaster_A  STASHmaster-meta.conf

Can you try making a STASHmaster directory within your app/um/file directory, and then moving your STASHmaster_A and STASHmaster-meta.conf files into it.

When you've done this and tested that it works, you might also want to fcm add the app/um/file directory before fcm commit-ing it, which will then also put the STASHmaster_A file under version control. Currently these don't exist in the repository.

Give this a go, and let me know how you get on.

Many thanks,
Luke

comment:2 Changed 3 years ago by marcus

Hi Luke,

This has now solved the problem, thank you very much.

So, in summary, this problem occurred because the model did not see the STASHmaster_A file. This was because the directory I had pointed to in rose-suite.conf did not exist.

It's worth noting that at the current version 10.6 the model has no mechanism to check whether the STASHmaster file actually exists when it is opened, i.e. iostat is not evaluated.

Many thanks,
Marcus

comment:3 Changed 3 years ago by luke

  • Resolution set to fixed
  • Status changed from new to closed

Hi Marcus,

Great - I'm glad that worked. Any other problems, please open a new ticket.

Thanks,
Luke

Note: See TracTickets for help on using tickets.