Opened 11 years ago

Closed 10 years ago

#221 closed error (fixed)

Error when submitting job , even though job has previously been submitted successfully.

Reported by: bethan.white Owned by: lois
Component: UM Model Keywords: Error submitting job
Cc: Platform:
UM Version: 6.1

Description

I have been trying to run a 4 km job on Hector using the working Hector test jobs posted on the NCAS website. When I ran the test jobs a few months ago, they worked. I have made some changes to the 4 km job and yesterday it submitted successfully. However, today when I tried to submit the same job, I get the following error:

SUBMIT:/etc/profile.d/mz_mazama.sh[21]: whence: -t: unknown option

I have gone back to the 12 km test job (unchanged from the one posted on the NCAS page) and tried to submit this, but get the same error message.

My TIC code is set to n02-ncas

Is there possibly something wrong with my account? I haven't changed any settings.

Thanks very much,
Bethan.

Change History (6)

comment:1 Changed 11 years ago by lois

  • Owner changed from um_support to lois
  • Status changed from new to assigned

Hello Bethan,

This error message is just a system error message which has no effect on your job. You need to look further down the .leave file to see what else it says. If you want me to look at your job you need to tell me which job in the UMUI you are running and change the file permissions so I can look at the .leave file itsels on HECToR.

Lois

comment:2 Changed 11 years ago by bethan.white

Hi Lois,

Thanks for getting back to me. Gerry and I looked further down the .leave file and couldn't see anything else in it that might help us. Also, after we received the error message we couldn't see the job on qstat.

The job is xdlud and I'll change the permissions on the .leave file for you.

Thanks,
Bethan.

comment:3 Changed 11 years ago by lois

Hello Bethan,

If you look at the .leave file towards the end there is the message

Mismatch in no of prognostic fields.

No of prog fields in Atmos dump 929
No of prog fields expected 932

Run RECONFIGURATION to get correct no of prognostic fields in atmos dump
or
Check/Reset? experiment in User Interface

So looking at your job in the UMUI, you are using the start dump
HC002_QM06_STD_4KMSTART
and you have in the UMUI the option in
atmosphere → model configuration → prognostic variable choices
total aerosol fields switched on. The HELP button for this option says
The "Total aerosol field" is used for visibility forecasting in the
mesoscale model and the standard set-up will use source/sink terms, and
advect the aerosol, and will supply boundary aerosol data for the UK mes
domain. Additionally, the radiative effects of these aerosols are also
accounted for in an approximate fashion, in both the short-wave and
long-wave, in the operational mesoscale model.

So you have 2 choices either you don't need visibility forescasting and you can turn off the total aerosol files option and your start dump is possibly compatible with this or you reconfigure and possibly your start dump is compatible with this choice.
Either way you need a start dump which is compatible with the options you select in the UMUI.

Let me know if there are further problems.

Lois

comment:4 Changed 11 years ago by bethan.white

Thanks Lois, I have been experiencing this problem with the start dump for a while and have been trying to make it compatible.

Can I just double check that if I see the error message

SUBMIT:/etc/profile.d/mz_mazama.sh[21]: whence: -t: unknown option

I don't need to worry about it?

Cheers,
Bethan.

comment:5 Changed 11 years ago by lois

Yes I can confirm you do not need to worry about the message

SUBMIT:/etc/profile.d/mz_mazama.sh[21]: whence: -t: unknown option

It is a system problem, nothing to do with your job at all.

Lois

comment:6 Changed 10 years ago by lois

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.