Opened 2 years ago

Closed 23 months ago

#2212 closed help (fixed)

Importing suites into Rosie on Monsoon

Reported by: apm Owned by: ros
Component: Monsoon Keywords: Rosie monsoon
Cc: dave.storkey@… Platform: Monsoon2
UM Version:

Description

I am using rose on xvmsrose, and am able to see the u- archive of suites.

When I try to copy or checkout a suite (in this instance, Dave Storkey's u-an659), Rosie hangs up and then crashes. I have successfully completed the "ssh Setup on Monsoon" procedure, but I wonder whether there is something else I need to do.

Thank you,

Alex

Change History (8)

comment:1 Changed 2 years ago by ros

Hi Alex,

I updated instructions for rose on Monsoon last week. Can you please check you've done everything on the following twiki page.

http://collab.metoffice.gov.uk/twiki/bin/view/Support/Monsoon2Rose

Cheers
Ros

comment:2 Changed 2 years ago by apm

Hi Ros,

Thanks for the prompt response.

I have a MOSRS account, I am using "ssh -Y” everywhere, I have no problem getting onto exvmsrose from the lander, and I can see Dave’s suite on the rosie-u repository from Rosie.

I am now working through the Authentication Caching section of the instructions, but in the "Authentication Caching Using GNOME Keyring” section it tells me to “run seahorse”. How do I do this? When I type “seahorse” on exvmsrose, I get

-bash: seahorse: command not found

Is there another way to do this step?

Regards,

Alex

comment:3 Changed 2 years ago by ros

Hi Alex,

On the authentication page there are section's for each site. You need to follow instructions for Monsoon which uses gpg-agent not Gnome keyring.

Cheers
Ros

comment:4 Changed 2 years ago by apm

Hi Ros,

I have completed everything on that page, including installing the two files mosrs-cache-password and mosrs-setup-gpg-agent, but I still get the same behaviour, with rosie crashing when I try to copy or checkout a suite. This happens even when the system has told me my password has been cached.

If I execute the scripts, I get

[almega@exvmsrose:~]$ ./mosrs-setup-gpg-agent
Met Office Science Repository Service password:
Subversion password cached
https://code.metoffice.gov.uk/rosie/u/hello: Hello AlexMegann?
Rosie password cached

[almega@exvmsrose:~]$ ./mosrs-cache-password
gpg-agent: no process killed
Error: gpg-agent not working
Run "mosrs-cache-password" to try caching your password again

Is this the behaviour you would expect?

Regards,

Alex

comment:5 Changed 2 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Alex,

You don't need to install the 2 mosrs scripts as they are installed centrally on Monsoon. You just need to do the Monsoon section of that page:
https://code.metoffice.gov.uk/trac/home/wiki/AuthenticationCaching#Monsoon

Specifically adding the Rose/Cylc path to your ~/.bash_profile and the mosrs setup to the end of your ~/.bashrc file.

Then you log out of exvmsrose and back in again where the you will be prompted for your MOSRS password in the same way that you are on PUMA.

The reason it doesn't work running on the command line in the way you have is because it has run the scripts in a new shell rather than the current shell.

Hope that helps.

Cheers,
Ros.

comment:6 Changed 2 years ago by apm

Thanks, Ros - that has definitely moved me forward, as now Rosie doesn't crash.

I'm still not there, though: when I try to copy Dave's suite I get this error:

RosePopenError?: svn commit -q -m u-an734:\ new\ suite,\ a\ copy\ of\ u-an659/trunk@44367 /var/tmp/tmpqOACtm/work #return-code-1, stderr=
svn: E165001: Commit failed (details follow):
svn: E165001: Commit blocked by pre-commit hook (exit code 1) with output:
2017-06-28T08:23:36Z+ 44671-z6e by alexmegann
A /n/7/¾/
A /n/7/¾/trunk/
U a/n/7/¾/trunk/rose-suite-info

[FAIL] NO SUCH USER: U a/n/7/¾/trunk/rose-suite-info: owner=AlexMegann?

Does this make any sense to you?

Alex

comment:7 Changed 2 years ago by apm

OK, changing the user name to lower case (thanks, Matthew!) has fixed this.

Alex

comment:8 Changed 23 months ago by ros

  • Platform changed from Other to Monsoon2
  • Resolution set to fixed
  • Status changed from accepted to closed
  • UM Version <select version> deleted
Note: See TracTickets for help on using tickets.