Opened 2 years ago

Closed 2 years ago

#2253 closed help (fixed)

Cannot access um in rose to edit STASH

Reported by: tstein Owned by: ros
Component: Rose/Cylc Keywords:
Cc: Platform:
UM Version: 10.6

Description

Hi,

I tried to add new domain profiles in my suite u-ao745 so that I could output COSP diagnostics.
I could not simply copy an existing profile, so had to clone an entire section.
Since that did not look correct, I wanted to undo my changes and the rose editor crashed.
I now can load my suite in rose, but cannot edit the "um" part of it anymore.

I have attached a PNG of the error I get.

I hope we can fix my suite!

Cheers,
Thorwald

Attachments (3)

rose_error.png (28.3 KB) - added by tstein 2 years ago.
Error screen in Rose
rose_clone.png (26.7 KB) - added by tstein 2 years ago.
Screen shot of cloned domain profile
rose_tidy_error.png (44.0 KB) - added by tstein 2 years ago.
Screen shot of error when running STASH Tidy Transform macro

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by tstein

Error screen in Rose

comment:1 Changed 2 years ago by ros

  • Component changed from UM Model to Rose/Cylc
  • Owner changed from um_support to ros
  • Status changed from new to accepted
  • UM Version changed from <select version> to 10.6

Hi Thorwold,

Looks like you've only made a couple of changes to the UM app so the easiest way to fix this will be to revert to the last committed version of the um/rose-app.conf file to before you made any of the STASH changes by running:

fcm revert /home/tstein/roses/u-ao745/app/um/rose-app.conf

Not sure what you did but you can copy(clone) a domain profile by going to namelist → Model input and output → STASH Requests and Profiles → Domain Profiles to get the list of all domain profiles. Right click on the profile you wish to copy and select 'Clone this section'. This will copy the profile to a new one with index "1". Modify the settings as appropriate. Before running the model you will need to run all the STASH macros to regenerate the hash indexes.

Cheers,
Ros.

comment:2 Changed 2 years ago by tstein

Hi Ros,

Thanks for the quick reply. I got back into the UM part now.

Now, the issue I have with running "clone this section" on one of my domain profiles is that it creates an entire new "domain" section, at the same level as the "model input and output" section (see attached figure rose_clone.png). Last time I tried to "clone" a profile, it simply created a new profile within the relevant section.

When I now want to run the STASH macros, "validate" works fine, but "transform" throws out another error (see attached figure rose_tidy_error.png).

Is there something wrong with my cloning set up?

Cheers,
Thorwald

Changed 2 years ago by tstein

Screen shot of cloned domain profile

Changed 2 years ago by tstein

Screen shot of error when running STASH Tidy Transform macro

comment:3 Changed 2 years ago by ros

Hi Thorwald,

The atm_soil, diag, etc domain profiles clone fine, as does the th_1_405eb352. After a bit of investigation I realised that the problem with the other domain profiles is caused by the name having a '-' in it. Looks like Rose can't handle copying a domain profile with a hash name containing a '-'.

The easiest solution would be if you could copy the th_1 domain profile and modify that (obviously don't use a hyphen in the new profile name). Would that be possible? Otherwise, we would need to rename the problem profiles, update the STASH requests and then regenerate the hashes indexes.

Cheers,
Ros.

comment:4 Changed 2 years ago by ros

A further note:

I have notified Stu of the problem and he will fix this in the standard suite u-aa753 in the next few days.

comment:5 Changed 2 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi Thorwald,

Just to let you know that Stu has updated the standard suite with this issue fixed.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.