#2256 closed help (fixed)

suite will not restart because STASHmaster file not found

Reported by: marcus Owned by: um_support
Component: Rose/Cylc Keywords: STASHMaster file, restart
Cc: Platform: Monsoon2
UM Version: 10.6

Description

Hi, I am trying to extend an earlier run of suite u-an366, which completed successfully, by two further years. As I have modified RUNLEN in /home/d03/makoe/roses/u-an366/rose-suite.conf I used rose suite-run --restart to set off the run.

The error I am getting is:

[makoe@exvmsrose:~/roses/u-an366]$ rose suite-run --restart
[INFO] delete: /home/d03/makoe/cylc-run/u-an366/log/rose-suite-run.host
[INFO] delete: log/rose-suite-run.conf
[INFO] symlink: rose-conf/20170831T094317-restart.conf <= log/rose-suite-run.conf
[INFO] delete: log/rose-suite-run.version
[INFO] symlink: rose-conf/20170831T094317-restart.version <= log/rose-suite-run.version
[INFO] export CYLC_VERSION=7.4.0
[INFO] export ROSE_ORIG_HOST=exvmsrose.monsoon-metoffice.co.uk
[INFO] export ROSE_VERSION=2017.05.0
[INFO] install: app
[INFO]     source: /home/d03/makoe/roses/u-an366/app
[FAIL] [Errno 2] No such file or directory: 'app/um/file/STASHmaster/app/um/file/STASHmaster/cylc-suite.db'
[FAIL] install: app/um/file/STASHmaster
[FAIL]     source: .

I originally had trouble setting the location of the STASHmaster file which was solved ticket #2208. All worked fine during the original run, but now at restart it seems to concatenate paths to a location which does not exist. I am a bit confused about what I need to change. Could you advise me please?

Many thanks,
Marcus

Change History (9)

comment:1 Changed 22 months ago by marcus

  • Component changed from UKCA to Rose/Cylc
  • priority changed from normal to high

comment:2 Changed 22 months ago by ros

  • priority changed from high to normal

Hi Marcus,

I have no idea how you've ended up with this but you somehow have another copy of the cylc-run/u-an366 directory embedded within the /home/d03/makoe/cylc-run/u-an366/app/um/file/STASHmaster directory. This has caused things to get rather screwed up.

My first suggestion would be to remove everything under /home/d03/makoe/cylc-run/u-an366/app/um/file/STASHmaster except for STASHmaster-meta.conf & STASHmaster_A and then try restarting the suite and see if that works.

If it doesn't then you will have to restart the suite by doing a new run, setting the input dump, etc to be the last dump/files from the end of the original run.

Regards,
Ros.

comment:3 Changed 22 months ago by marcus

Hi Ros,

Thanks for your suggestion. I have tried this now and deleted all the superfluous files from the STASHmaster directory prior to restarting. However, the command rose suite-run --restart then recreates again the other copy of the cylc-run/u-an366 directory within SUITE/app/um/file/STASHmaster.

I believe it must be something within my Rose configuration. u-ap862 is a copy of u-an366 and it has the same problems when I restart, so it's reproducable.

Is there anything wrong how I point to my customised STASHmaster file within Rose? The purpose of this experiment is to include additional chemical tracers and diagnostics.

Best,
Marcus

comment:4 Changed 22 months ago by ros

Hi Marcus,

The problem is caused by your change to the rose-suite.conf file

[file:app/um/file/STASHmaster]
source='.'

This says copy everything from the current working directory (which is ~/cylc-run/u-an366) into the ~/cylc-run/u-an366/app/um/file/STASHmaster directory!

You might be able to get away with just changing source='.' to source=

However, the correct way of using a STASHmaster file from within a suite is documented here under section "Aternative method": https://code.metoffice.gov.uk/doc/um/vn10.8/um-training/stashmaster.html#case_2

Cheers,
Ros.

comment:5 Changed 22 months ago by ros

Hi Marcus,

I realised that what I said above about changing source='.' to source= that was daft. You just need to remove the following entirely.

[file:app/um/file/STASHmaster]
source='.'

As you've put the STASHmaster within the suite you therefore don't need to tell it to copy it over.

Cheers,
Ros.

comment:6 follow-up: Changed 22 months ago by marcus

Hi Ros,

Thank you, this has indeed let me restart my suite. I still have a question about this, because I want to understand this properly.

At the moment I have removed the entry

[file:app/um/file/STASHmaster]
source='.'

from rose-suite.conf entirely which has worked, the suite restarted successfully. As far as I understand this is all good because I have a STASHmaster_A file in $SUITEDIR/app/um/file/STASHmaster/, i.e. within the suite subdirectory.

I've had a look at the um-training pages weblink that you sent me above. According to Case Scenario 2 (Alternative Method) I should have the following entry in in $SUITEDIR/app/um/rose-app.conf:

[env]
STASHMSTR=.

In my suite this is however set to

[env]
STASHMSTER=STASHmaster

I don't quite understand what this environment variable does. Does it point to the location where the STASHmaster_A file is, relative to $SUITEDIR/app/um/file/?

In other words, if I moved my STASHmaster_A file to app/um/file it should be changed to STASHMSTER=.?

Many thanks,
Marcus

comment:7 Changed 22 months ago by marcus

Apologies, I meant STASHMSTR in the above, not STASHMSTER.
Marcus

comment:8 in reply to: ↑ 6 Changed 22 months ago by ros

Replying to marcus:

I don't quite understand what this environment variable does. Does it point to the location where the STASHmaster_A file is, relative to $SUITEDIR/app/um/file/?

In other words, if I moved my STASHmaster_A file to app/um/file it should be changed to STASHMSTER=.?

Yes this is absolutely correct. :-)

comment:9 Changed 22 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.