Opened 3 months ago

Last modified 2 months ago

#2282 pending help

Upgrade to cylc and the subsequent postprocessing failure KeyError: 'CYLC_SUITE_REG_NAME'

Reported by: freyagarry Owned by: um_support
Priority: normal Component: UM Model
Keywords: Cc:
Platform: Monsoon2 UM Version: 10.1

Description

Hi,

u-aq321 on Monsoon is failing on post-processing. I understand from http://cms.ncas.ac.uk/ticket/2176 that this is because I recently updated the cylc version.

I tried to follow the instructions in the ticket above to insert a branch that would fix the problem, and then re-triggered fcm_make_pp but I can't fix the issue. As I am running vn10.1 instead of vn10.3 in the above ticket, I tried several vn10.1 branches (finding them through searching https://code.metoffice.gov.uk/trac/um/search?q=CYLC_SUITE_REG_NAME&noquickjump=1&changeset=on&milestone=on&ticket=on&wiki=on) but they either don't seem to work for me or have conflicts with the other branches in fcm_make_pp/Configuration.

Please can you advise?

Cheers,
Freya

Change History (3)

comment:1 Changed 3 months ago by annette

Note: discussion continued over email.

comment:2 Changed 3 months ago by willie

  • Status changed from new to pending

comment:3 Changed 2 months ago by ros

Original email response:

OK. You need to replace occurrences of CYLC_SUITE_REG_NAME with CYLC_SUITE_NAME.

For speed, as you need to get this working this afternoon, the easiest is just to change the scripts in the suite direct to get you going then fix it properly in a branch when you get back. Use grep in ~/cylc-run/u-aq321/share/fcm_make_pp/build/bin to replace occurrences in those scripts.

Let me know if you have any problems putting a fix into a branch.

Cheers,
Ros.

Note: See TracTickets for help on using tickets.