Opened 2 months ago

Last modified 7 weeks ago

#2294 accepted help

No rule to make target error.

Reported by: 21001998 Owned by: ros
Priority: normal Component: JULES
Keywords: Cc:
Platform: ARCHER UM Version:

Description

Hi

I am currently getting the error,
gmake: * No rule to make target model_time_mod.o', needed by sf_impl2.o'. Stop.

in /home/n02/n02/jtalib/output/xnngj000.xnngj.d17279.t112559.comp.leave

I am trying to use two modified branches, the first is a JULES branch, /home/jtalib/branches/JULES_prescribe_LH and the second is an atmospheric branch, /home/jtalib/branches/vn8.5_prescribing_LH .

I have made changes to sf_impl2_jls.F90 in JULES, but unsure how to resolve this error. I noticed your FAQs page but unsure where the JULES script components would be on ARCHER?

Kind regards, Josh.

Change History (7)

comment:1 Changed 2 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Josh,

In src/science/surface/sf_impl2_jls.F90 (line 74) you don't need the

! DEPENDS ON: model_time_mod

before a USE statement.

Try removing that line and see if that fixes the problem.

Cheers,
Ros.

comment:2 Changed 2 months ago by 21001998

Hi Ros,

That was an addition I added to try and make it work.

I've removed the line and still no luck.

Current .leave file,
xnngk000.xnngk.d17285.t151355.comp.leave

Could it be due to the fact that I call timestep_mod twice. I was having merging issues and thought it would be easier just to call the module twice.

Kind regards,
Josh.

comment:3 Changed 8 weeks ago by ros

Hi Josh,

You have 4 files in your vn8.5_prescribing_LH branch that are empty;

src/control/top_level/sf_impl2_jls.F90
src/control/top_level/atmos_step_4A.F90
src/atmosphere/boundary_layer/bdy_layr1.F90
src/atmosphere/boundary_layer/imps_solver.F90

Please remove these as they are causing the compiler problems.

You will then get some FORTRAN errors in prescribe_LH_mod.F90 which you will need to fix.

Cheers,
Ros.

comment:4 Changed 8 weeks ago by 21001998

Hi Ros,

Thanks for your help. How did you find the empty files?

Once deleting the files, the Fortran errors appeared. However, once making the appropriate changes I get the same error again.

/home/n02/n02/jtalib/output/xnngp000.xnngp.d17290.t164030.comp.leave

I assume I have accidently created another empty file. How can I get rid of it.

Thanks once again,
Josh.

comment:5 Changed 8 weeks ago by ros

Hi Josh,

I found the empty files because I ran fcm status to see what changes you had made and looked at all the files you had added and found some empty. You don't have any more.

Looking at your code changes in src/science/surface/sf_impl2_jls.F90 I now see the problem. model_time_mod is only for use with standalone Jules. If you look at all its other occurrences they are only used if UM_JULES is not defined. E.g.

#if defined(UM_JULES)
USE timestep_mod, ONLY: timestep
USE science_fixes_mod, ONLY: l_emis_ssi_full
#else
USE model_time_mod, ONLY: timestep_len
#endif

model_time_mod.F90 is not extracted in UM jobs, additionally its contents is also within an #if !defined(UM_JULES).

Hope that helps.
Cheers,
Ros.

comment:6 Changed 8 weeks ago by 21001998

Hi Ros,

Thank you for your help! Definitely need to improve my FORTRAN coding skills. I have changed my code so model_time_mod doesn't need to be called. The model now builds successfully, however issues arise during reconfiguration?

? Error Message: Total number of processors does not fit EW/NS LPG???!!!???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!???!!!?

? Error generated from processor:     0? Error in routine: Rcf_Initialise

? This run generated   0 warnings? Error Code:    50
? Error Message: Total number of processors does not fit EW/NS LPG

I looked at ticket http://cms.ncas.ac.uk/ticket/137 however changing the number of processors did not resolve the issue.

Any ideas where I'm going wrong?

Kind regards,
Josh.

comment:7 Changed 7 weeks ago by ros

Hi Josh,

Quick question: can you confirm that this job ran successfully without your changes in?

Cheers,
Ros.

Note: See TracTickets for help on using tickets.