Opened 11 months ago

Closed 9 months ago

#2330 closed help (answered)

NEMO crash on Archer under ROSE/CYLC

Reported by: apm Owned by: um_support
Priority: normal Component: NEMO/CICE
Keywords: Cc:
Platform: ARCHER UM Version: <select version>

Description

I have been getting crashes in my NEMO/CICE configurations which appear to be related to the way Rose creates the NEMO namelist. When this particular failure mode occurs, my ocean.output file tells me that the last action was to try to read the ice shelf melting flux, but it appears to have a non-alphanumeric string for the name of the associated land mask file (NEMO does not require this file, but still doesn't respond well to the illegal characters).

I see that the NEMO namelist namelist_cfg has two spaces at the end of the line specifying the file for runoff (sn_rnfisf). This corresponds to the two empty boxes in the entry for sn_rnfisf on the Rose GUI page under NEMO/Surface boundary conditions/Ice shelves. The model seems to requite an extra argument at the end of this line, and its absence leads to an uninitialised character string. This can crash NEMO on Archer (though it doesn't seem to be fatal when running the same configuration on Monsoon)

If I edit the namelist in between submission and the job running, I can prevent the crash, but whenever Cylc restarts for a new cycle, or I restart the job from the command line, it resets the namelist and the model is likely to fail. Is there any way to add an extra box in Rose so the namelist is created correctly?

Thanks,

Alex

Change History (12)

comment:1 Changed 11 months ago by jeff

Hi Alex

Have you got a suite-id which has this problem?

Jeff.

comment:2 Changed 10 months ago by apm

That's strange - I thought I had replied to you straight away, but I don't see anything.

The two suites I am currently having this trouble with are u-ao882 and u-ao922.

Thanks,

Alex

comment:3 Changed 10 months ago by apm

Any news on this?

Thanks,

Alex

comment:4 Changed 10 months ago by apm

Do you think this is something I could fix myself?

Alex

comment:5 Changed 10 months ago by grenville

Alex

Glad you found a workaround - we're looking at this, but have only a skeleton crew for the next few weeks.

Grenville

comment:6 Changed 10 months ago by grenville

Alex

It's odd that Rose doesn't understand the extra entry in the NEMO FLD_N data structure. The metadata needs to be changed to fix the problem.

If instead of using ocean_ice/GO6/nemo36_gsi8 for the nemo-cice meta data, you can try with /home/grenville/meta/apm-nemo/ocean_ice/GO6/nemo36_gsi8, you'll see an extra box for sn_rnfisf (and sn_depmax_isf - I didn't change anything else).

Please copy this metadata (I may remove it by mistake)

If you try this, you'll initially see a set of entries (your current entries) for sn_rnfisf which are not rendered with widgets - on adding a "," to the list, the widgets will appear [not sure why this happens], then you can set the extra field as you wish.

To do this, I edited /home/grenville/meta/apm-nemo/ocean_ice/nemo/v3.6_GO6_CO6/rose-meta.conf - simply by adding an extra "character" to the "type" entry for [namelist:namsbc_isf=sn_rnfisf]. The help text is now out of sync, but that's beyond me.

I hope this gets you past having to tweak the namelists by hand - an alternative would be to modify the code to better handle the missing entry (prob not the right approach).

I've not investigated if this bug has been fixed centrally - maybe Andrew could advise?

Grenville

comment:7 Changed 10 months ago by apm

Dear Grenville,

Thanks for your reply.

I'm afraid I am lost here. Where do I change the specification of the metadata source? Do I need to edit a file somewhere on Puma, or do I do it through the Rose GUI?

I see you have a directory on Puma /home/grenville/meta/ , but I didn't have a meta directory under my account. I've just created one and copied your nemo36_gsi8 directory there. I can then link to my copy rather than yours.

Regards,

Alex

comment:8 Changed 10 months ago by grenville

Hi Alex

In the Rose GUI, click on "nemo_cice" - the word, not the little triangle. That's where you specify the path to the metadata. Apply the change, then either quit and reopen, or click on Metadata (in the tool bar) and Refresh Metadata.

My copy of your job (/home/grenville/roses/u-ao882) has the changes if you'd like to see before trying them out.

Grenville

comment:9 Changed 10 months ago by apm

Hi Grenville,

That seems to have fixed the problem - thanks.

There is a second, and quite similar, issue with the Puma version of the GO6 suite. In the GO6 suite I have on Monsoon (u-an735) there is a box under nemo_cice/file that lets me specify the location and file name of the iodef.xml that NEMO uses. On the Puma suite, by contrast, I can't find where the iodef file is chosen - it's certainly not in nemo_cice/file. In fact I don't understand where Rose gets the original iodef.xml to put in the run directory, which makes it difficult to make changes to it. Is it possible to add a box in the Rose GUI for this file?

Thanks,

Alex

comment:10 Changed 9 months ago by grenville

Alex

Just add (with the appropriate path)

[file:iodef.xml]
source=/home/d01/almega/iodef_files/iodef_orca025_4h.xml

to

~/roses/u-ao882/app/nemo_cice/rose-app.conf

Probably best to move the existing ~/roses/u-ao882/app/nemo_cice/file directory. Alternatively (& just as easy) — put the appropriate iodef file in ~/roses/u-ao882/app/nemo_cice/file.

Grenville

comment:11 Changed 9 months ago by apm

Thanks, Grenville - that worked, and I now have much proper control of my iodef!

Regards,

Alex

comment:12 Changed 9 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.