#2343 closed error (fixed)

Problem creating ozone ancilary with Xancil

Reported by: s1374103 Owned by: um_support
Component: UKCA Keywords: xancil ozone
Cc: Platform:
UM Version: 8.4

Description

Hi Helpdesk,

I have created an ozone climatology netcdf (STRAT_ozone_TS_2005_2015.nc) file and I am trying to use xancil to convert it into an ancillary file. To see my xancil setup, please see /projects/ukca-ed/kjamie/jakel/ancillaries/AR5_2000/ozone_attempt_1.job.

When I try to create the ancillary, I get the following error message;

Writing Ozone ancillary file
/projects/ukca-ed/kjamie/ancillaries/AR5_2000/straT_pre.anc
Error: in procedure get ncatt text 1: NetCDF error number -49
NetCDF: variable not found: dim1

is sounds like xancil is searching for dimension, dim1, but cannot find it, but at this point, I don't know what dim1 is.

If I do;
ncdup -h STRAT_ozone_TS_2005_2015.nc

I get the following;

dimensions:
	time = UNLIMITED ; // (12 currently)
	dim1 = 85 ;
	latitude = 145 ;
	longitude = 1 ;
	bnds = 2 ;
	string64 = 64 ;

So actually, dim1 is there, and it appears to be the vertical dimension.

I'm super confused now. Do you have any idea what the problem is?

Regards,

Jamie

Change History (2)

comment:1 Changed 22 months ago by s1374103

Hi,

This is no longer a problem, so you can close the ticket now.

I renamed the dimension, 'dim1', to 'level' and it worked.

Regards,

Jamie

Last edited 22 months ago by s1374103 (previous) (diff)

comment:2 Changed 22 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by reporter.

Note: See TracTickets for help on using tickets.