Opened 3 months ago

Closed 3 months ago

#2361 closed help (fixed)

Requested STASH not outputted

Reported by: shakka Owned by: um_support
Priority: normal Component: UM Model
Keywords: STASH Cc:
Platform: Monsoon2 UM Version: 10.4

Description

Hi CMS,

I'm having issues with getting the UM to output all the STASH codes I have requested. I added some new STASH requests (cloud microphysical ones) via the rose GUI, and some of them are being outputted, but others aren't. I have checked that they are compatible with the usage, time and domain profiles I have set up, and I am fairly sure that they are. Also, some variables that were previously outputted fine are now missing (e.g. radiative fluxes at the surface), though I haven't changed them.

On a related note, lots of the variables are now named extremely helpful things like 'stash code = 16206' rather than their STASHmaster or standard names, which means I'm having to trawl through the STASHmaster file to figure out what they are.

Is this some kind of problem with my STASHmaster file do you think? Do you have any idea how I can fix this?

The suite I'm running is u-ai781.

Thanks,

Ella

Change History (5)

comment:1 Changed 3 months ago by willie

Hi Ella,

What isn't outputting the STASH? Is it in the glm_um_fcst* or is it one of the Peninsula forecasts. What cycle time does it occur at?

On your second point, I have a utility on monsoon ~frmy/bin/check_stash which you runs as follows,

$ check_stash 16 206 10.4
1|    1 |   16 |  206 |CLOUD WATER CONTENT (qc)            |

Regards
Willie

comment:2 Changed 3 months ago by willie

Hi Ella,

There are some STASH items that are not available to your model:

find . -name job.err -exec  grep "request denied" {} \;
?          Field - Section:0, Item:271 request denied.
?          Field - Section:9, Item:10 request denied.
?          Field - Section:9, Item:207 request denied.
?          Field - Section:0, Item:271 request denied.
?          Field - Section:9, Item:10 request denied.
?          Field - Section:9, Item:207 request denied.
frmy@exvmsrose$ check_stash 0 271 10.4
1|    1 |    0 |  271 |CLOUD ICE (CRYSTALS) AFTER TIMESTEP |
frmy@exvmsrose$ check_stash 9 10 10.4
1|    1 |    9 |   10 |SPEC. HUMIDITY AFTER MAIN DYN CLOUD |
frmy@exvmsrose$ check_stash 9 207 10.4
1|    1 |    9 |  207 |CLOUD ICE CONTENT AFTER DYNAM CLOUD |

I think these occur in Peninsula_km4p0_PC2_um_fcst_000. Are these the problematic ones?

Regards
Willie

comment:3 Changed 3 months ago by shakka

Hi Willie,

Thanks for your reply, those are some of the problematic ones, yes, and I'm getting the problem in the Peninsula forecasts (1.5 km and 4 km), rather than the glm ones. I'm also unable to get surface shortwave and longwave fluxes (1201/1202/2201/2217/2218). As to the cycle times, I'm just not getting them in the files produced at all, as far as I can see.

Can you see any reason for that?

Best,
Ella

comment:4 Changed 3 months ago by shakka

Hi Willie,

I have realised what the problem is: I had changed the forecast length to be 12 hours, but the profile I was using to output the diagnostics only starts outputting from t=12, therefore I wasn't getting them all. I've fixed this now and I'm able to get all the requested diagnostics.

Thanks for your help (I knew it would be something silly and simple that I had done).

Kind regards,

Ella

comment:5 Changed 3 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed

Hi Ella,

Glad you've sorted it.

Regards
Willie

Note: See TracTickets for help on using tickets.