Opened 8 months ago

Closed 8 months ago

#2364 closed help (fixed)

Compiling on ARCHER

Reported by: cthomas Owned by: um_support
Priority: normal Component: UM Model
Keywords: puma, ARCHER, umui, NEMO, GC2 Cc:
Platform: ARCHER UM Version: 8.6

Description

Hi all,

I am trying to set up the HadGEM3-GC2 configuration to run on ARCHER. Using the umui, I have made a copy of the xkcfe job (as listed on this page) and have been modifying it to compile and run the various model components. By default quite a few of the paths are pointing to directories in the n02 workspace, which I don't have access to since I am in n01. I have changed as many of these as possible to point to /work/y07/y07/umshared but get the following build error when compiling NEMO/CICE:

/opt/cray/hdf5/1.10.0.1/CRAY/8.3/lib/libhdf5.a(H5PL.o): In function `H5PL__open$$CFE_id_56395c9c_a2f1556b':
/b/ulib/hdf5-support/rpm/BUILD/cray-hdf5-1.10.0.1-201612052137.d5c01d2b84e7c-cce1-serial/hdf5-1.10.0-patch1/src/H5PL.c:614: warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/work/y07/y07/umshared/oasis/oasis3_3/20110919_para_MxSeg1500/prism/crayxc30_cce/lib/libpsmile.MPI1.a(mod_psmile_io.o): In function `psmile_io_init_comp_':
/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:262: undefined reference to `flush_'
/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:273: undefined reference to `flush_'
/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:281: undefined reference to `flush_'
/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:290: undefined reference to `flush_'
/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:310: undefined reference to `flush_'
/work/y07/y07/umshared/oasis/oasis3_3/20110919_para_MxSeg1500/prism/crayxc30_cce/lib/libpsmile.MPI1.a(mod_psmile_io.o):/home/n02/n02/karthee/oasis/oasis3_3/20110919_para_MxSeg1500/prism/lib/psmile/src/mod_psmile_io.F90:317: more undefined references to `flush_' follow
/opt/cray/cce/8.3.7/cray-binutils/x86_64-unknown-linux-gnu/bin/ld: link errors found, deleting executable `nemo.exe'
fcm_internal load failed (256)
gmake: *** [nemo.exe] Error 1

This is referencing a file in n02 - is that the cause of the problem or is it something else? If it's useful I can provide the full log file.

By the way, if this has been ported to rose I'd be interested to know - using rosie go I can find many suites described as HadGEM3 or GC2 but they don't seem to appear together.

Thanks,
Chris

Change History (7)

comment:1 Changed 8 months ago by willie

Hi Chris,

It is reading the file OK, it's just not happy about the contents. It might be an idea to do a clean build from scratch.

I had a quick look at your set up and the only further things I would suggest are

  • Set the GCOM collectives limit from 64 to 1. (Independent Section → Miscellaneous ..)
  • In user script release, the directory specified doesn't exist. You can find the files on Monsoon under ~jwalton/ported/scripts/GC2.0. So copy that over the ARCHER and point to it on the user script release page. (Control → Post Processing.. → User)

Regards
Willie

comment:2 Changed 8 months ago by grenville

Chris

Why could you not use GC3 - we have Rose suites for that config + I believe the start data for the GC2 job you have no longer exists.

Grenville

comment:3 Changed 8 months ago by cthomas

Hi Grenville,

I'm definitely not opposed to that idea - maybe I can explain what I'm trying to do. I have produced some ocean-only assimilation output using the GO5 configuration and I would like to use that to initialise some coupled ocean-atmosphere runs. The aim of the runs is to study the difference between including and excluding certain data in the assimilation. I was hoping to use the same ocean model in these tests as in the assimilation in order to keep as many things the same as possible. However, as long as the changes between GO5 and GO6 are reasonably small then it shouldn't matter too much, especially since I will be taking the difference between two model runs.

I'd just need to check whether restart files produced by GO5 can be used in GO6 (as far as I understand the grid has been extended southwards in GO6, and the version of NEMO has been updated). Also, I am trying to get a reasonably realistic atmospheric restart file from the same period (~2010). I have an idea how to do this but if you have any advice that would be great.

Best wishes,
Chris

PS Willie - thanks for the help - I'll let you know if I move to GC3 or not.

comment:4 Changed 8 months ago by cthomas

Hello,

Just to let you know I got the code to compile by using the following option in Compilation and Run OptionsOASIS Coupling Switches and OptionsLocation of OASIS3 build:

$OASIS_BLDS/20110919_para_MxSeg1500/prism/crayxc30_cce_May2015

This was initially

$OASIS_BLDS/20110919_para_MxSeg1500/prism/crayxc30_cce 

I basically guessed that the latest directory is the right one to use…

Regarding the user scripts, I'm not quite sure where Control → Post Processing → User is. Can you please let me know?

Thanks,
Chris

comment:5 Changed 8 months ago by willie

Hi Chris,

I meant Atmosphere →Control > Post Processing … → User script release

Regards
Willie

comment:6 Changed 8 months ago by cthomas

Hi Willie,

Thanks. I've now managed to compile the code and run it for a day. I used the NEMO and CICE outputs from my assimilation together with the 19810901 atmospheric startdump (which is clearly wrong but it was useful for testing).

Cheers,
Chris

comment:7 Changed 8 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.