#2373 closed help (fixed)

Time profiles

Reported by: s.varma13 Owned by: um_support
Component: UM Model Keywords: mean time profiles
Cc: Platform: Monsoon2
UM Version: 10.8

Description

Hi, I have been running two suites, one outputting monthly means u-au333 (current) and the other outputting daily means u-as983 (finished). I have looked at one of the daily files from u-as983 and it does not look right which makes me doubt whether I inputted the correct variables/numbers in the two time profiles. Could you please have a look at the screenshot of the two mean profiles and let me know if they are correct? TDAYM for daily means and TMNMEAN for monthly means

Many thanks

Sunil

Attachments (1)

Time_profiles.docx (2.8 MB) - added by s.varma13 20 months ago.
Mean time profiles screenshot

Change History (13)

Changed 20 months ago by s.varma13

Mean time profiles screenshot

comment:1 Changed 20 months ago by s.varma13

Hi, I was wondering if anyone was able to look at this. Many thanks. Sunil

comment:2 Changed 20 months ago by willie

Hi Sunil,

You say that one of the daily files from u-as982 "does not look right". Which file are you looking at? Can you say in what way it is wrong?

Regards
Willie

comment:3 Changed 20 months ago by s.varma13

Hi Willie

The data range is correctly set between 0 and 1 but the data has too many data points either equalling only 1 or only 0. I just wanted to make sure that I have plotted the time profile correctly and this is an issue with the data and not with my time profile. If I have daily mean profiled incorrectly then I my monthly mean time profiles is incorrect so jusy wanted someone to check that I had profiled these two correctly.

Many thanks

Sunil

comment:4 Changed 20 months ago by s.varma13

Sorry loads of spelling mistakes in my last message.

The data range is correctly set between 0 and 1 but the data has too many data points either equalling only 1 or only 0. I just wanted to make sure that I have plotted the time profile correctly and this is an issue with the data and not with my daily mean time profile. If I have daily mean profiled incorrectly then my monthly mean time profiles will also be incorrect so I just wanted someone to check that I had profiled these two correctly.

comment:5 Changed 20 months ago by willie

Sorry Sunil, Which daily file are you looking at?

Willie

comment:6 Changed 20 months ago by s.varma13

Hi WIllie, could you have a look at any of the files produced for u-as983. They are all daily files. moo ls moose:/crum/u-as983/apd.pp

However all I need is a quick glance of the file I attached to my original message to see if I have put the correct numbers etc. into the time profile TDAYM and TMNMEAN so that the output is respectively a daiy mean and monthly mean.

Many thanks

Sunil

comment:7 Changed 20 months ago by willie

Hi Sunil,

I looked at moose:/crum/u-as983/apd.pp/as983a.pd20090122.pp as a specific example. There seemed to be some diagnostics missing e.g.

BULK CLOUD VOL INCR: swrad scheme

which is supposed to be output in on two different domains according to the STASH table. But the main problem is the errors in the STASH table.

If you modify the STASH, then you need to runs the validate (TidySTASHvalidate) and transform (TidySTASHTransform) macros check for errors and to rebuild the STASH indices. See the STASH macros slide in http://cms.ncas.ac.uk/documents/training/December2017/UM_Introduction_Presentations.pdf.

Once you have fixed these issue you should run the job again.

Regards,
Willie

comment:8 Changed 20 months ago by s.varma13

Thanks a lot Willie.

I will do that but that should not have affected the other diagnostics and I ignored this as in the end I did not need Bulk Cloud Volume. The diagnostics that looks weird are all the other cloud diagnostics that did output.

For future simulations could you still have a look at the time profiles I am using to confirm that they are daily and monthly mean profiles?

Many thanks

Sunil

comment:9 Changed 20 months ago by s.varma13

Hi Willie

I had used the TidySTASHTransform previously and have just used TidySTASHvalidate which told me that I had 2 duplicates in the STASH list, neither of which I had chosen to output. Would this have made any difference to the run? I will re-run it anyway but I am still not convinced that I have set up my daily mean or monthly mean time profile correctly.

Many thanks

Sunil

comment:10 Changed 20 months ago by willie

Hi Sunil,

It looks like you've run this with the improved STASH. I looked at the low cloud amount in as983a.pd20090122.pp in xconv today and couldn't see any indication of errors, but I am not a meteorologist. It looks like a daily mean. The daily mean profile as far as I can see seems alright ( I don't think it was changed from the original job).

Let me know if there are still problems with this.

Regards
Willie

comment:11 Changed 20 months ago by s.varma13

Hi Willie

Thank you. I was not sure when I opened the ticket whether the low cloud amount was wrong as a result of my time profile. I now know that both are correct so that has really helped me. I can trust the data.

Best wishes

Sunil

comment:12 Changed 20 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.