Opened 3 weeks ago

Closed 9 days ago

Last modified 6 days ago

#2382 closed help (answered)

simulation failed to output feb2000 monthly mean

Reported by: s.varma13 Owned by: willie
Priority: normal Component: UM Model
Keywords: Gregorian Cc:
Platform: Monsoon2 UM Version: 10.8

Description

Hi, I am running three simulations from 1988 to 2015 (u-au329, u-au333 and u-au341).

All three were started at different times and all three have reached 2001 - 2002 and are still running.

Files being outputted are all monthly mean files and every year has a complete 12 months set except 2000. All three are missing Feb2000.

I had thought that this was because there was an issue with it being a leap year but I have set up the runs under the Gregorian calendar and all the other leap years have outputted feb.

I have not been able to work out why.

Could you please help me find out?

Many thanks

Sunil

Change History (6)

comment:1 Changed 2 weeks ago by willie

  • Keywords Gregorian added
  • Owner changed from um_support to willie
  • Platform set to Monsoon2
  • Status changed from new to accepted
  • UM Version changed from <select version> to 10.8

Hi Sunil,

I have started to look at this. It is very similar to #1902, but the methods there haven't worked. I will keep you posted.

Regards
Willie

comment:2 Changed 2 weeks ago by s.varma13

Hi Willie

Many thanks. The strange thing with mine is that it is outputting monthly means but every simulation has failed to produce the February 2000 file.

Best wishes

Sunil

comment:3 Changed 12 days ago by willie

Hi Sunil,

I took a copy of your job, fixed the STASH errors and ran it starting from Jan 2000 for three months. This is u-au816. It has run successfully and produced au816a.pd2000efeb. There was a Monsoon glitch at the end of the Feb 2000 run that caused a failure (I've reported this) and I just re-triggered to finish the run.

Regards
Willie

comment:4 Changed 12 days ago by s.varma13

Hi Willie

Thanks a lot.

What changes did you make to the STASH so I can repeat these in my simulations?

Does it matter that in your run u-au816, the astart dump file is still 1988? When I redo these runs to output for just Feb2000, presumably I will have to change the astart date to the start dump file auxxxa.da20000101_00, switch off build and reconfigure and then do suite-run —restart?

Best wishes

Sunil

comment:5 Changed 9 days ago by willie

  • Resolution set to answered
  • Status changed from accepted to closed

Hi Sunil,

I ran the STASH macros to detect the problems.

I see that you also have #2392 referring to the same suite. It's not a good idea to do this since multiple people can be working on the same suite, making changes and interfering with each others thought processes, so I'll close this ticket.

Willie

Last edited 9 days ago by willie (previous) (diff)

comment:6 Changed 6 days ago by s.varma13

Hi Willie,

Thanks for this.

So al I have to do is run Macros button > stash_indices.TidyStashTransform? and stash_requests.StashProfilesValidate?, change the model basis time to Jan 2000, the astart start dump to Jan 2000 and then run as a new suite?

Sunil

Note: See TracTickets for help on using tickets.