Opened 3 months ago

Closed 3 months ago

#2398 closed help (fixed)

Reconfiguration error

Reported by: cthomas Owned by: um_support
Priority: normal Component: UM Model
Keywords: reconfiguration Cc:
Platform: ARCHER UM Version: 8.6

Description

Hi,

After downloading the startdump mentioned in ticket #2385 I submitted a UM job on Archer and ran into the following error during reconfiguration:

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR        ???!!!???!!!???!!!???!!!???!!!???!!!
?  Error   Code:    30
?  Error   Message: Section   0 Item   101 : Required field is not in input dump!
?  Error   from processor:     0
?  Error   number:     1
????????????????????????????????????????????????????????????????????????????????

Looking at ticket #1538 I noticed these scripts are mentioned:

~wmcginty/bin/reqd_fields
~wmcginty/bin/dump_fields

Is it still recommended to use these scripts to solve this issue? If so would it be OK for you to put them on Monsoon please? (I can't access n02.)

Thanks,
Chris

Change History (7)

comment:1 Changed 3 months ago by willie

Hi Chris,

Those are old scripts designed for vn8.2, so probably not useful now.

You started with a UM dump so I think there won't be too many fields like this. The field in question is SO2 MASS MIXING RATIO AFTER TSTEP. If you don't need this you could switch it off (Section 17 Sulphur cycle) or, failing that, specify it in the Initialisation of User Prognostics page and set the appropriate option.

Regards
Willie

comment:2 Changed 3 months ago by cthomas

Hi Willie,

I've now disabled everything in Section 17 (Aerosols) and also Section 26 (River Routing). The reconfiguration gets a bit further but now has the following problem:

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR        ???!!!???!!!???!!!???!!!???!!!???!!!
?  Error   Code:     1
?  Error   Message: StashCode is not a valid prognostic variable, Stash Code     121
?  Error   from processor:     0
?  Error   number:     1
????????????????????????????????????????????????????????????????????????????????

This looks very similar to ticket #841 but I have not managed to fix it yet. Do you have any recommendations?
Thanks,
Chris

comment:3 Changed 3 months ago by grenville

Chris

Please put the leave file in /work/n01/shared (or /work/n02/shared) -

Grenville

comment:4 Changed 3 months ago by cthomas

Hi Grenville,

It is here: /work/n01/shared/cmthomas/xnwea000.xnwea.d18044.t230608.rcf.leave

Thanks,
Chris

comment:5 Changed 3 months ago by grenville

Chris

Just a guess go to - model selection→Atmosphere→ancil & input..→climatologies→sulphur-cylce emissions (3D)

change from configured to not used

Grenville

comment:6 Changed 3 months ago by cthomas

Hi Grenville,

That worked - the reconfiguration proceeded without any problems. Thanks a lot!
Chris

comment:7 Changed 3 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.